aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoracm <acm@FreeBSD.org>2018-06-03 15:57:10 +0800
committeracm <acm@FreeBSD.org>2018-06-03 15:57:10 +0800
commitfcc36f4fb6c45d14c36dd1cd8cd230453bbaa04f (patch)
treec2fcfef9c42071ed3d8514c722ab7450859fe89c
parent9d327c514776f0bdcf1e80562bc7feefe4d41e88 (diff)
downloadfreebsd-ports-gnome-fcc36f4fb6c45d14c36dd1cd8cd230453bbaa04f.tar.gz
freebsd-ports-gnome-fcc36f4fb6c45d14c36dd1cd8cd230453bbaa04f.tar.zst
freebsd-ports-gnome-fcc36f4fb6c45d14c36dd1cd8cd230453bbaa04f.zip
- Update to 3.6.15
-rw-r--r--editors/coedit/Makefile5
-rw-r--r--editors/coedit/distinfo6
-rw-r--r--editors/coedit/files/patch-dastworx_build.sh12
3 files changed, 13 insertions, 10 deletions
diff --git a/editors/coedit/Makefile b/editors/coedit/Makefile
index a2c85fd5df66..64f1b1a348c4 100644
--- a/editors/coedit/Makefile
+++ b/editors/coedit/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= coedit
-PORTVERSION= 3.6.4
+PORTVERSION= 3.6.15
DISTVERSIONPREFIX=v
CATEGORIES= editors
PKGNAMESUFFIX= ${LAZARUS_PKGNAMESUFFIX}
@@ -13,7 +13,8 @@ LICENSE= BSL
BUILD_DEPENDS= ldmd2:lang/ldc \
${LOCALBASE}/lib/d/libiz.a:devel/iz \
- ${LOCALBASE}/lib/d/libdparse.a:devel/libdparse
+ ${LOCALBASE}/lib/d/libdparse.a:devel/libdparse \
+ ${LOCALBASE}/lib/d/libstdx-allocator.a:devel/stdx-allocator
RUN_DEPENDS= ldmd2:lang/ldc \
dscanner:devel/d-scanner \
dcd-client:devel/dcd-client \
diff --git a/editors/coedit/distinfo b/editors/coedit/distinfo
index dea069623050..cb706ae130b6 100644
--- a/editors/coedit/distinfo
+++ b/editors/coedit/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1520727939
-SHA256 (BBasile-Coedit-v3.6.4_GH0.tar.gz) = afed9234facf9683e0de3620f97d2f00e4b35aae38e7b39b3bd5333ba3278052
-SIZE (BBasile-Coedit-v3.6.4_GH0.tar.gz) = 3862290
+TIMESTAMP = 1528011225
+SHA256 (BBasile-Coedit-v3.6.15_GH0.tar.gz) = 0ba71193560784460a7b36ae24e96be211f91aec14776b2bcafeb0597f0fdedd
+SIZE (BBasile-Coedit-v3.6.15_GH0.tar.gz) = 3879879
diff --git a/editors/coedit/files/patch-dastworx_build.sh b/editors/coedit/files/patch-dastworx_build.sh
index 7f62b06fd6ce..6a8c0317fdfe 100644
--- a/editors/coedit/files/patch-dastworx_build.sh
+++ b/editors/coedit/files/patch-dastworx_build.sh
@@ -1,5 +1,5 @@
---- dastworx/build.sh 2018-02-11 21:48:35.000000000 -0500
-+++ dastworx/build.sh 2018-02-12 12:01:10.311013000 -0500
+--- dastworx/build.sh 2018-06-03 02:41:09.063965000 -0500
++++ dastworx/build.sh 2018-06-03 02:42:21.888100000 -0500
@@ -1,18 +1,3 @@
-#iz sources
-cd ../etc/iz/import/
@@ -19,15 +19,17 @@
#dast sources
cd src/
dast=$(find `pwd` -type f -name \*.d)
-@@ -21,9 +6,9 @@
+@@ -21,10 +6,10 @@
echo building...
#build
-dmd ${dast[@]} ${dparse[@]} ${iz[@]} ${stdxalloc[@]} \
-+%%LDMD2_CMD%% ${dast} \
++%%LDMD2_CMD%% ${dast} \
-O -release -inline -boundscheck=off \
--Isrc -I../etc/iz/import -I../etc/libdparse/src -I../etc/stdx-allocator/source \
+--of../bin/dastworx
+-Isrc -I%%D_INCLUDE_DIR%% -L%%D_LIB_DIR%%/libiz.a -L%%D_LIB_DIR%%/libdparse.a \
- -of../bin/dastworx
++-L%%D_LIB_DIR%%/libstdx-allocator.a -of../bin/dastworx
#cleanup
+ rm ../bin/dastworx.o