aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorsem <sem@FreeBSD.org>2004-12-11 12:21:02 +0800
committersem <sem@FreeBSD.org>2004-12-11 12:21:02 +0800
commitfcd3942324b3ff90122d2efdecd4022e604b8f01 (patch)
tree608e3aabef28ee0006264dabc78d0602d79c487d
parent7a153b380c3f616086388f2abb69701044ba263d (diff)
downloadfreebsd-ports-gnome-fcd3942324b3ff90122d2efdecd4022e604b8f01.tar.gz
freebsd-ports-gnome-fcd3942324b3ff90122d2efdecd4022e604b8f01.tar.zst
freebsd-ports-gnome-fcd3942324b3ff90122d2efdecd4022e604b8f01.zip
- Add patch from Shen Chun-Hsing for stardict2's TTS support
- Update a maintainer E-Mail PR: ports/74449 Submitted by: maintainer Obtained from: http://netlab.cse.yzu.edu.tw/~statue/outta-port/patch-src::readword.cpp
-rw-r--r--textproc/stardict2/Makefile4
-rw-r--r--textproc/stardict2/files/patch-src::readword.cpp29
-rw-r--r--textproc/stardict3/Makefile4
-rw-r--r--textproc/stardict3/files/patch-src::readword.cpp29
4 files changed, 62 insertions, 4 deletions
diff --git a/textproc/stardict2/Makefile b/textproc/stardict2/Makefile
index 8cc7895ea323..8951efebda1e 100644
--- a/textproc/stardict2/Makefile
+++ b/textproc/stardict2/Makefile
@@ -7,13 +7,13 @@
PORTNAME= stardict
PORTVERSION= 2.4.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DIST_SUBDIR= stardict
-MAINTAINER= delphij@FreeBSD.org.cn
+MAINTAINER= delphij@FreeBSD.org
COMMENT= A cross-platform and international dictionary written in Gtk2
GNU_CONFIGURE= yes
diff --git a/textproc/stardict2/files/patch-src::readword.cpp b/textproc/stardict2/files/patch-src::readword.cpp
new file mode 100644
index 000000000000..111abbf783b1
--- /dev/null
+++ b/textproc/stardict2/files/patch-src::readword.cpp
@@ -0,0 +1,29 @@
+--- src/readword.cpp.orig Sat Nov 27 22:35:44 2004
++++ src/readword.cpp Sat Nov 27 22:36:00 2004
+@@ -18,7 +18,7 @@
+ have_data_file = g_file_test(filename, G_FILE_TEST_EXISTS);
+ g_free(filename);
+ #else
+- have_data_file = g_file_test("/usr/share/WyabdcRealPeopleTTS", G_FILE_TEST_EXISTS);
++ have_data_file = g_file_test("/usr/local/share/WyabdcRealPeopleTTS", G_FILE_TEST_EXISTS);
+ #endif
+ }
+
+@@ -34,7 +34,7 @@
+ #ifdef _WIN32
+ gchar *filename = g_strdup_printf("%s/WyabdcRealPeopleTTS/%c/%s.wav", stardict_data_dir, lowerword[0],lowerword);
+ #else
+- gchar *filename = g_strdup_printf("/usr/share/WyabdcRealPeopleTTS/%c/%s.wav", lowerword[0],lowerword);
++ gchar *filename = g_strdup_printf("/usr/local/share/WyabdcRealPeopleTTS/%c/%s.wav", lowerword[0],lowerword);
+ #endif
+ return_val = g_file_test(filename, G_FILE_TEST_EXISTS);
+ g_free(filename);
+@@ -56,7 +56,7 @@
+ filename = g_strdup_printf("%s/WyabdcRealPeopleTTS/%c/%s.wav", stardict_data_dir, lowerword[0],lowerword);
+ PlaySound(filename, 0, SND_ASYNC | SND_FILENAME);
+ #else
+- filename = g_strdup_printf("/usr/share/WyabdcRealPeopleTTS/%c/%s.wav", lowerword[0],lowerword);
++ filename = g_strdup_printf("/usr/local/share/WyabdcRealPeopleTTS/%c/%s.wav", lowerword[0],lowerword);
+ gnome_sound_play(filename);
+ #endif
+ g_free(filename);
diff --git a/textproc/stardict3/Makefile b/textproc/stardict3/Makefile
index 8cc7895ea323..8951efebda1e 100644
--- a/textproc/stardict3/Makefile
+++ b/textproc/stardict3/Makefile
@@ -7,13 +7,13 @@
PORTNAME= stardict
PORTVERSION= 2.4.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= textproc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
DIST_SUBDIR= stardict
-MAINTAINER= delphij@FreeBSD.org.cn
+MAINTAINER= delphij@FreeBSD.org
COMMENT= A cross-platform and international dictionary written in Gtk2
GNU_CONFIGURE= yes
diff --git a/textproc/stardict3/files/patch-src::readword.cpp b/textproc/stardict3/files/patch-src::readword.cpp
new file mode 100644
index 000000000000..111abbf783b1
--- /dev/null
+++ b/textproc/stardict3/files/patch-src::readword.cpp
@@ -0,0 +1,29 @@
+--- src/readword.cpp.orig Sat Nov 27 22:35:44 2004
++++ src/readword.cpp Sat Nov 27 22:36:00 2004
+@@ -18,7 +18,7 @@
+ have_data_file = g_file_test(filename, G_FILE_TEST_EXISTS);
+ g_free(filename);
+ #else
+- have_data_file = g_file_test("/usr/share/WyabdcRealPeopleTTS", G_FILE_TEST_EXISTS);
++ have_data_file = g_file_test("/usr/local/share/WyabdcRealPeopleTTS", G_FILE_TEST_EXISTS);
+ #endif
+ }
+
+@@ -34,7 +34,7 @@
+ #ifdef _WIN32
+ gchar *filename = g_strdup_printf("%s/WyabdcRealPeopleTTS/%c/%s.wav", stardict_data_dir, lowerword[0],lowerword);
+ #else
+- gchar *filename = g_strdup_printf("/usr/share/WyabdcRealPeopleTTS/%c/%s.wav", lowerword[0],lowerword);
++ gchar *filename = g_strdup_printf("/usr/local/share/WyabdcRealPeopleTTS/%c/%s.wav", lowerword[0],lowerword);
+ #endif
+ return_val = g_file_test(filename, G_FILE_TEST_EXISTS);
+ g_free(filename);
+@@ -56,7 +56,7 @@
+ filename = g_strdup_printf("%s/WyabdcRealPeopleTTS/%c/%s.wav", stardict_data_dir, lowerword[0],lowerword);
+ PlaySound(filename, 0, SND_ASYNC | SND_FILENAME);
+ #else
+- filename = g_strdup_printf("/usr/share/WyabdcRealPeopleTTS/%c/%s.wav", lowerword[0],lowerword);
++ filename = g_strdup_printf("/usr/local/share/WyabdcRealPeopleTTS/%c/%s.wav", lowerword[0],lowerword);
+ gnome_sound_play(filename);
+ #endif
+ g_free(filename);