aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoralexbl <alexbl@FreeBSD.org>2006-11-19 08:29:57 +0800
committeralexbl <alexbl@FreeBSD.org>2006-11-19 08:29:57 +0800
commitfecfc2005a3252bf285951dc3fe9d952c7d9afd8 (patch)
tree3386e678175e4ec9accd7a309aac69e71e74a3a8
parent38c700758bd3f40700f87c4de5a8b2efc71565dd (diff)
downloadfreebsd-ports-gnome-fecfc2005a3252bf285951dc3fe9d952c7d9afd8.tar.gz
freebsd-ports-gnome-fecfc2005a3252bf285951dc3fe9d952c7d9afd8.tar.zst
freebsd-ports-gnome-fecfc2005a3252bf285951dc3fe9d952c7d9afd8.zip
- Do not append version number to f2py executable
PR: 105641 Submitted by: Diane Bruce <db@db.net> Reviewed by: myself
-rw-r--r--lang/f2py/Makefile1
-rw-r--r--lang/f2py/files/patch-setup.py11
2 files changed, 12 insertions, 0 deletions
diff --git a/lang/f2py/Makefile b/lang/f2py/Makefile
index 1aac18ca40e3..c4c27c697161 100644
--- a/lang/f2py/Makefile
+++ b/lang/f2py/Makefile
@@ -8,6 +8,7 @@
PORTNAME= f2py
PORTVERSION= 2.45.241.1926
+PORTREVISION= 1
CATEGORIES= lang python
MASTER_SITES= http://cens.ioc.ee/projects/f2py2e/2.x/
DISTNAME= ${PORTNAME:U}-${PORTVERSION:R}_${PORTVERSION:E}
diff --git a/lang/f2py/files/patch-setup.py b/lang/f2py/files/patch-setup.py
new file mode 100644
index 000000000000..41c3c018fb76
--- /dev/null
+++ b/lang/f2py/files/patch-setup.py
@@ -0,0 +1,11 @@
+--- setup.py.orig Sun Jan 30 12:22:14 2005
++++ setup.py Thu Nov 16 18:46:25 2006
+@@ -40,7 +40,7 @@
+ f2py2e.main()
+ '''%(os.path.basename(sys.executable))
+
+-f2py_exe = 'f2py'+os.path.basename(sys.executable)[6:]
++f2py_exe = 'f2py'
+ if f2py_exe[-4:]=='.exe':
+ f2py_exe = f2py_exe[:-4] + '.py'
+ if 'bdist_wininst' in sys.argv and f2py_exe[-3:] != '.py':