aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-05-03 21:33:48 +0800
committerbapt <bapt@FreeBSD.org>2013-05-03 21:33:48 +0800
commitfffc9140bcc4aea24ced35e1a286497f4b65198d (patch)
tree13d065098ecbb45962ded477a0320ab55e7e6713
parent1be1f541b0e1a1d0d45f3fceca5cd814d1591141 (diff)
downloadfreebsd-ports-gnome-fffc9140bcc4aea24ced35e1a286497f4b65198d.tar.gz
freebsd-ports-gnome-fffc9140bcc4aea24ced35e1a286497f4b65198d.tar.zst
freebsd-ports-gnome-fffc9140bcc4aea24ced35e1a286497f4b65198d.zip
Fix build with bmake by using gmake if make is bmake
-rw-r--r--graphics/ecore-evas/Makefile3
-rw-r--r--graphics/evas-engine-opengl/Makefile7
-rw-r--r--graphics/evas-engine-sdl/Makefile3
3 files changed, 12 insertions, 1 deletions
diff --git a/graphics/ecore-evas/Makefile b/graphics/ecore-evas/Makefile
index 9a362ba2c1ad..3ce306571abb 100644
--- a/graphics/ecore-evas/Makefile
+++ b/graphics/ecore-evas/Makefile
@@ -17,6 +17,9 @@ LICENSE= BSD
DIST_SUBDIR= e17
USE_BZIP2= yes
GNU_CONFIGURE= yes
+.if defined(.PARSEDIR)
+USE_GMAKE= yes
+.endif
USE_EFL= evas ecore libtool_hack
USE_EFL_ECORE= input input_evas
USE_LDCONFIG= yes
diff --git a/graphics/evas-engine-opengl/Makefile b/graphics/evas-engine-opengl/Makefile
index 48b98dc081e5..d5caf7209087 100644
--- a/graphics/evas-engine-opengl/Makefile
+++ b/graphics/evas-engine-opengl/Makefile
@@ -19,6 +19,11 @@ LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2
DIST_SUBDIR= e17
USE_BZIP2= yes
GNU_CONFIGURE= yes
+MYMAKE= ${MAKE}
+.if defined(.PARSEDIR)
+USE_GMAKE= yes
+MYMAKE= ${GMAKE}
+.endif
USE_EFL= evas librt_hack libtool_hack
USE_XORG= x11 xext xrender
USE_GL= gl glu
@@ -38,7 +43,7 @@ post-patch:
pre-build:
@(cd ${WRKSRC}/src/modules/engines/gl_common; ${SETENV} ${MAKE_ENV} \
- ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
+ ${MYMAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${ALL_TARGET})
post-install:
${INSTALL_DATA} ${WRKSRC}/evas-opengl-x11.pc \
diff --git a/graphics/evas-engine-sdl/Makefile b/graphics/evas-engine-sdl/Makefile
index 1296943b5a0a..b0c9f252e7cf 100644
--- a/graphics/evas-engine-sdl/Makefile
+++ b/graphics/evas-engine-sdl/Makefile
@@ -19,6 +19,9 @@ LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2
DIST_SUBDIR= e17
USE_BZIP2= yes
GNU_CONFIGURE= yes
+.if defined(.PARSEDIR)
+USE_GMAKE= yes
+.endif
USE_EFL= evas librt_hack libtool_hack
USE_SDL= sdl
USE_LDCONFIG= yes