aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2014-06-16 06:47:10 +0800
committerbapt <bapt@FreeBSD.org>2014-06-16 06:47:10 +0800
commit64d841a29c63823a5f2bf74449ab9a7d0c0f6148 (patch)
tree4cdfe0fd3981178f3816dd4ed37423707ebce574 /Makefile
parentcf26975a80b6ebbe84d54c5c0d14677642062032 (diff)
downloadfreebsd-ports-gnome-64d841a29c63823a5f2bf74449ab9a7d0c0f6148.tar.gz
freebsd-ports-gnome-64d841a29c63823a5f2bf74449ab9a7d0c0f6148.tar.zst
freebsd-ports-gnome-64d841a29c63823a5f2bf74449ab9a7d0c0f6148.zip
Add a mechanism to allow updating the ports tree with rsync
PR: 171681 Submitted by: cyberleo@cyberleo.net
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/Makefile b/Makefile
index 34977ee79625..8b8f9d6f2395 100644
--- a/Makefile
+++ b/Makefile
@@ -162,6 +162,7 @@ print-index: ${INDEXDIR}/${INDEXFILE}
GIT?= git
SVN?= svn
+RSYNC?= rsync
PORTSNAP?= portsnap
PORTSNAP_FLAGS?= -p ${.CURDIR}
.if !target(update)
@@ -176,6 +177,11 @@ update:
@echo ">>> Updating ${.CURDIR} from git+svn repository"
@echo "--------------------------------------------------------------"
cd ${.CURDIR}; ${GIT} svn rebase
+.elif defined(RSYNC_UPDATE) && defined(PORTS_RSYNC_SOURCE)
+ @echo "--------------------------------------------------------------"
+ @echo ">>> Updating with ${RSYNC} from ${PORTS_RSYNC_SOURCE}"
+ @echo "--------------------------------------------------------------"
+ @${RSYNC} ${RSYNC_FLAGS} ${PORTS_RSYNC_SOURCE}/ ${.CURDIR}/
.else
@echo "--------------------------------------------------------------"
@echo ">>> Running ${PORTSNAP}"