aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>2000-04-12 19:06:35 +0800
committerasami <asami@FreeBSD.org>2000-04-12 19:06:35 +0800
commitc565387c5b04f04923b820a556455af67290b52c (patch)
tree87f58ef135b4a97b9d821a5e84164361ff9c1bd4 /Makefile
parentb124ccb2e6f5749a5c3cea36aeb45e36e2bcd7c3 (diff)
downloadfreebsd-ports-gnome-c565387c5b04f04923b820a556455af67290b52c.tar.gz
freebsd-ports-gnome-c565387c5b04f04923b820a556455af67290b52c.tar.zst
freebsd-ports-gnome-c565387c5b04f04923b820a556455af67290b52c.zip
Change a couple of "make"s to "cd ${.CURDIR} && make"s, otherwise you
will get "make: don't know how to make /usr/ports/INDEX. Stop" type of weird errors when /usr/obj${.CURDIR} exists.
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/Makefile b/Makefile
index 574860414da0..d8738c83dba3 100644
--- a/Makefile
+++ b/Makefile
@@ -53,11 +53,11 @@ PORTSTOP= yes
index:
@rm -f ${.CURDIR}/INDEX
- @make ${.CURDIR}/INDEX
+ @cd ${.CURDIR} && make ${.CURDIR}/INDEX
${.CURDIR}/INDEX:
@echo -n "Generating INDEX - please wait.."
- @make describe ECHO_MSG="echo > /dev/null" | \
+ @cd ${.CURDIR} && make describe ECHO_MSG="echo > /dev/null" | \
perl ${.CURDIR}/Tools/make_index > ${.CURDIR}/INDEX
.if !defined(INDEX_NOSORT)
@sed -e 's./..g' ${.CURDIR}/INDEX | \