aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Uses/libtool.mk
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-09-29 00:36:31 +0800
committertijl <tijl@FreeBSD.org>2014-09-29 00:36:31 +0800
commite7dc30958a42e788cc3320e65536192f3476ef87 (patch)
treeaeb03f1aa94222d62e9cdc28c4130adb5b0e5327 /Mk/Uses/libtool.mk
parentccd08de0500ddc8e427dc1bbf85fc534336cc7f8 (diff)
downloadfreebsd-ports-gnome-e7dc30958a42e788cc3320e65536192f3476ef87.tar.gz
freebsd-ports-gnome-e7dc30958a42e788cc3320e65536192f3476ef87.tar.zst
freebsd-ports-gnome-e7dc30958a42e788cc3320e65536192f3476ef87.zip
Change the way USES is handled:
- Loop over USES twice, once to define all *_ARGS variables and once to include Uses/*.mk. This allows all Uses/*.mk to examine arguments given to other USES entries. - Always define *_ARGS (possibly empty) and replace commas with spaces. Similar for _USES_POST. Adjust all Uses/*.mk: - defined(u_ARGS) becomes !empty(u_ARGS) - Eliminate helper variables like _*_ARGS=${*_ARGS:C/,/ /g} - Some Uses/*.mk used ":" as argument separator instead of ",", but no port used this form - Uses/cran.mk: remove unused variable VALID_ARGS and USES+=fortran which has no effect - Uses/twisted.mk: simplify handling of the case where neither "build" nor "run" arguments have been specified PR: 193931 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'Mk/Uses/libtool.mk')
-rw-r--r--Mk/Uses/libtool.mk1
1 files changed, 0 insertions, 1 deletions
diff --git a/Mk/Uses/libtool.mk b/Mk/Uses/libtool.mk
index f8e928185931..118128795f3c 100644
--- a/Mk/Uses/libtool.mk
+++ b/Mk/Uses/libtool.mk
@@ -16,7 +16,6 @@
.if !defined(_INCLUDE_USES_LIBTOOL_MK)
_INCLUDE_USES_LIBTOOL_MK= yes
_USES_POST+= libtool
-libtool_ARGS:= ${libtool_ARGS:C/,/ /}
.if ${libtool_ARGS:Mbuild}
BUILD_DEPENDS+= libtool:${PORTSDIR}/devel/libtool