aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Uses/objc.mk
diff options
context:
space:
mode:
authorDavid Chisnall <theraven@FreeBSD.org>2015-07-01 21:50:28 +0800
committerDavid Chisnall <theraven@FreeBSD.org>2015-07-01 21:50:28 +0800
commitb6546ca2ca951bdc8b431343e865526c04422088 (patch)
tree768c0d7e8d779c0a07374b2216328f05189ef2df /Mk/Uses/objc.mk
parent554eff90f57c1db49150a6fe5bc405a8db7fa4d9 (diff)
downloadfreebsd-ports-gnome-b6546ca2ca951bdc8b431343e865526c04422088.tar.gz
freebsd-ports-gnome-b6546ca2ca951bdc8b431343e865526c04422088.tar.zst
freebsd-ports-gnome-b6546ca2ca951bdc8b431343e865526c04422088.zip
Update GNUstep ports to their latest versions.
Also fix a few bits of generic infrastructure along the way. Approved by: bapt (mentor) Differential Revision: https://reviews.freebsd.org/D2961
Diffstat (limited to 'Mk/Uses/objc.mk')
-rw-r--r--Mk/Uses/objc.mk7
1 files changed, 5 insertions, 2 deletions
diff --git a/Mk/Uses/objc.mk b/Mk/Uses/objc.mk
index 41ec8914a4ce..96888a8ebd6b 100644
--- a/Mk/Uses/objc.mk
+++ b/Mk/Uses/objc.mk
@@ -10,8 +10,9 @@
.if !defined(_INCLUDE_USES_OBJC_MK)
_INCLUDE_USES_OBJC_MK= yes
-.if !empty(objc_ARGS)
-IGNORE= USES=objc takes no arguments
+objc_ARGS?=
+.if !empty(objc_ARGS) && ! ${objc_ARGS:Mcompiler}
+IGNORE= USES=objc only accepts no arguments or 'compiler'
.endif
_CCVERSION!= ${CC} --version
@@ -56,9 +57,11 @@ LDFLAGS+= -B${LOCALBASE}/bin
.endif
.endif
+.if ! ${objc_ARGS:Mcompiler}
LIB_DEPENDS+= libobjc.so.4.6:${PORTSDIR}/lang/libobjc2
OBJCFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+.endif
CONFIGURE_ENV+= OBJC="${CC}" OBJCFLAGS="${OBJCFLAGS}"
MAKE_ENV+= OBJC="${CC}" OBJCFLAGS="${OBJCFLAGS}"