aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Uses/perl5.mk
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-06-10 20:14:12 +0800
committermat <mat@FreeBSD.org>2014-06-10 20:14:12 +0800
commitd4ba2ee310de35fc89a3aa0df9bd3994df0e1c06 (patch)
treeaeafd6b72a8d3be86af00681d166956acc8e815f /Mk/Uses/perl5.mk
parentca7b30fe9e4d4f2f6cb72fab91b3b414edba4b52 (diff)
downloadfreebsd-ports-gnome-d4ba2ee310de35fc89a3aa0df9bd3994df0e1c06.tar.gz
freebsd-ports-gnome-d4ba2ee310de35fc89a3aa0df9bd3994df0e1c06.tar.zst
freebsd-ports-gnome-d4ba2ee310de35fc89a3aa0df9bd3994df0e1c06.zip
Remove all the bootstrap files (.bs) from the plists.
Starting with perl 5.20, they're not installed any more if empty, and on FreeBSD, they're (always ?) empty. PR: 190681 Submitted by: mat Exp-Run by: antoine Sponsored by: Absolight
Diffstat (limited to 'Mk/Uses/perl5.mk')
-rw-r--r--Mk/Uses/perl5.mk8
1 files changed, 5 insertions, 3 deletions
diff --git a/Mk/Uses/perl5.mk b/Mk/Uses/perl5.mk
index a284c68e08ff..7f203804ee35 100644
--- a/Mk/Uses/perl5.mk
+++ b/Mk/Uses/perl5.mk
@@ -264,9 +264,11 @@ fix-packlist::
-@[ -d ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}/${PERL_ARCH}/auto ] && ${FIND} ${STAGEDIR}${PREFIX}/${SITE_PERL_REL}/${PERL_ARCH}/auto -name .packlist -exec ${SED} -i '' 's|^${STAGEDIR}||' '{}' \;
.endif
-.if ${PERL_LEVEL} >= 502000
-fix-plist-perl:
- -@${REINPLACE_CMD} '/\.bs$$/d' ${TMPPLIST}
+# Starting with perl 5.20, the empty bootstrap files are not installed any
+# more. As we don't need them anyway, remove it altogether.
+.if ${PERL_LEVEL} < 502000
+fix-perl-bs:
+ -@${FIND} ${STAGEDIR} -name '*.bs' -size 0 -delete
.endif
.if !target(regression-test)