aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Uses/perl5.mk
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-09-19 16:16:43 +0800
committerbapt <bapt@FreeBSD.org>2013-09-19 16:16:43 +0800
commite96411f7bd3a8c50ad224e7597bfabac5d3365fc (patch)
tree05d309c8525dca581e8ee3aab697d460af0220cd /Mk/Uses/perl5.mk
parent6e792276d33efbc93e8d6333669e7def8301851a (diff)
downloadfreebsd-ports-gnome-e96411f7bd3a8c50ad224e7597bfabac5d3365fc.tar.gz
freebsd-ports-gnome-e96411f7bd3a8c50ad224e7597bfabac5d3365fc.tar.zst
freebsd-ports-gnome-e96411f7bd3a8c50ad224e7597bfabac5d3365fc.zip
Introduce the one-true-way to handle multi version ports
This defines a new macros for end users! DEFAULT_VERSIONS. This macros is used to end-users to define what version they want to be the default version for the whole ports tree (for ports allowing that) Syntax is the following: DEFAULT_VERSIONS= perl5=5.18 ruby=2.0 Swith bsd.ruby.mk to use it[1], switch Uses/perl5.mk to use it[2] If you are maintaining settable multi version port, please change it so it uses DEFAULT_VERSIONS. Reviewed by: ruby (swills) [1], perl (az) [2] Approved by: ruby (swills) [1], perl (az) [2]
Diffstat (limited to 'Mk/Uses/perl5.mk')
-rw-r--r--Mk/Uses/perl5.mk13
1 files changed, 12 insertions, 1 deletions
diff --git a/Mk/Uses/perl5.mk b/Mk/Uses/perl5.mk
index 0024e4811294..aff1649ddd68 100644
--- a/Mk/Uses/perl5.mk
+++ b/Mk/Uses/perl5.mk
@@ -46,7 +46,18 @@ USE_PERL5?= run build
PERL_VERSION!= perl -e 'printf "%vd\n", $$^V;'
.endif
.else
-PERL_VERSION?= 5.14.4
+.include "${PORTSDIR}/Mk/bsd.default-versions.mk"
+.if ${PERL5_DEFAULT} == 5.12
+PERL_VERSION= 5.12.5
+.elif ${PERL5_DEFAULT} == 5.14
+PERL_VERSION= 5.14.4
+.elif ${PERL5_DEFAULT} == 5.16
+PERL_VERSION= 5.16.3
+.elif ${PERL5_DEFAULT} == 5.18
+PERL_VERSION= 5.18.1
+.else
+IGNORE= Invalid perl5 version ${PERL5_DEFAULT}
+.endif
.endif
PERL_VER?= ${PERL_VERSION:C/\.[0-9]+$//}