aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Uses
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2013-04-27 04:44:59 +0800
committermva <mva@FreeBSD.org>2013-04-27 04:44:59 +0800
commit0068a8a89d5baf4dd73c4d0ca465f11f620488a5 (patch)
treed27cdff0d227680d343d75197345b90220100457 /Mk/Uses
parent7ec651eeaa2551aa98b7d2e26cf09d6e5f315d68 (diff)
downloadfreebsd-ports-gnome-0068a8a89d5baf4dd73c4d0ca465f11f620488a5.tar.gz
freebsd-ports-gnome-0068a8a89d5baf4dd73c4d0ca465f11f620488a5.tar.zst
freebsd-ports-gnome-0068a8a89d5baf4dd73c4d0ca465f11f620488a5.zip
Introduces USES= iconv to replace USE_ICONV.
It takes no arguments. This deprecates USE_ICONV, please convert your ports. USE_ICONV will be removed as soon as it is no more used in the ports tree. Approved by: portmgr (bapt)
Diffstat (limited to 'Mk/Uses')
-rw-r--r--Mk/Uses/iconv.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/Mk/Uses/iconv.mk b/Mk/Uses/iconv.mk
new file mode 100644
index 000000000000..5a325bb1a350
--- /dev/null
+++ b/Mk/Uses/iconv.mk
@@ -0,0 +1,21 @@
+# $FreeBSD$
+#
+# handle dependency on the iconv port
+#
+# MAINTAINER: portmgr@FreeBSD.org
+#
+# Feature: iconv
+# Usage: USES=iconv
+# Valid ARGS: does not require args
+#
+#
+.if !defined(_INCLUDE_USES_ICONV_MK)
+_INCLUDE_USES_ICONV_MK= yes
+
+.if defined(iconv_ARGS)
+IGNORE= USES=iconv does not require args
+.endif
+
+LIB_DEPENDS+= iconv.3:${PORTSDIR}/converters/libiconv
+
+.endif