aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Uses
diff options
context:
space:
mode:
authorantoine <antoine@FreeBSD.org>2015-06-23 02:30:35 +0800
committerantoine <antoine@FreeBSD.org>2015-06-23 02:30:35 +0800
commit12a8a1a36e28266a42a3514596fb27fbd50618dc (patch)
treef433f5b1776fd92ce1a8f78039c8196b54f8e049 /Mk/Uses
parentfa31a64fa0833b29473cf4c13e65e4e0d580f824 (diff)
downloadfreebsd-ports-gnome-12a8a1a36e28266a42a3514596fb27fbd50618dc.tar.gz
freebsd-ports-gnome-12a8a1a36e28266a42a3514596fb27fbd50618dc.tar.zst
freebsd-ports-gnome-12a8a1a36e28266a42a3514596fb27fbd50618dc.zip
Add USES=jpeg, to handle dependency on a jpeg library
Differential Revision: https://reviews.freebsd.org/D1582 Reviewed by: bapt, mat
Diffstat (limited to 'Mk/Uses')
-rw-r--r--Mk/Uses/jpeg.mk33
1 files changed, 33 insertions, 0 deletions
diff --git a/Mk/Uses/jpeg.mk b/Mk/Uses/jpeg.mk
new file mode 100644
index 000000000000..1aaf07fba08f
--- /dev/null
+++ b/Mk/Uses/jpeg.mk
@@ -0,0 +1,33 @@
+# $FreeBSD$
+#
+# Handle dependency on jpeg
+#
+# Feature: jpeg
+# Usage: USES=jpeg or USES=jpeg:ARGS
+# Valid ARGS: lib (default, implicit), build, run, both
+#
+# MAINTAINER: portmgr@FreeBSD.org
+
+.if !defined(_INCLUDE_USES_JPEG_MK)
+
+_INCLUDE_USES_JPEG_MK= yes
+JPEG_PORT?= graphics/jpeg
+
+.if empty(jpeg_ARGS)
+jpeg_ARGS= lib
+.endif
+
+.if ${jpeg_ARGS} == lib
+LIB_DEPENDS+= libjpeg.so:${PORTSDIR}/${JPEG_PORT}
+.elif ${jpeg_ARGS} == build
+BUILD_DEPENDS+= cjpeg:${PORTSDIR}/${JPEG_PORT}
+.elif ${jpeg_ARGS} == run
+RUN_DEPENDS+= cjpeg:${PORTSDIR}/${JPEG_PORT}
+.elif ${jpeg_ARGS} == both
+BUILD_DEPENDS+= cjpeg:${PORTSDIR}/${JPEG_PORT}
+RUN_DEPENDS+= cjpeg:${PORTSDIR}/${JPEG_PORT}
+.else
+IGNORE= USES=jpeg - invalid args: [${jpeg_ARGS}] specified
+.endif
+
+.endif