aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Uses
diff options
context:
space:
mode:
authorbeat <beat@FreeBSD.org>2014-12-03 22:55:25 +0800
committerbeat <beat@FreeBSD.org>2014-12-03 22:55:25 +0800
commit4ada0905f426db8e0a22d973dffb8401bc442d6f (patch)
tree1a32479f5df7c300e66e4b2c4ca0ed5c4bfe2463 /Mk/Uses
parentd73e6c902b4b51ed28eff10428e9feaddcd71d44 (diff)
downloadfreebsd-ports-gnome-4ada0905f426db8e0a22d973dffb8401bc442d6f.tar.gz
freebsd-ports-gnome-4ada0905f426db8e0a22d973dffb8401bc442d6f.tar.zst
freebsd-ports-gnome-4ada0905f426db8e0a22d973dffb8401bc442d6f.zip
- Update Thunderbird to 31.3.0
- Update gmp-api to 35.0 - Update openh264 to 1.2 - Update NSS to 3.17.3 - Update Firefox to 34.0.5 - Update Firefox ESR 31.3.0 - Update libxul to 31.3.0 - Improve CONFIGURE_TARGET handling - Always build using client.mk - Switch to clang by default on systems without libc++ (/stable/8 and /stable/9) - Drop lang/python2 dependency, only lang/python27 is required to build - Use DuckDuckGo searchplugin from upstream (has suggestions and purposes) - Backport a few about:memory fixes - Backport Web Notifications libnotify integration - Add GTK3 option for www/firefox. Adwaita is a bit broken since Gtk 3.14, see: https://bugzilla.mozilla.org/show_bug.cgi?id=1073117 PR: 195559 Submitted by: Jan Beich MFH: 2014Q4 Security: http://vuxml.org/freebsd/7ae61870-9dd2-4884-a2f2-f19bb5784d09.html
Diffstat (limited to 'Mk/Uses')
-rw-r--r--Mk/Uses/gecko.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/Mk/Uses/gecko.mk b/Mk/Uses/gecko.mk
index caa755ec9109..2b0e2abd2418 100644
--- a/Mk/Uses/gecko.mk
+++ b/Mk/Uses/gecko.mk
@@ -37,12 +37,12 @@ RUN_DEPENDS+= libxul>=31:${PORTSDIR}/www/libxul
.elif ${gecko_ARGS:Mfirefox}
_GECKO_DEFAULT_VERSION= 31
-_GECKO_VERSIONS= 31 33
+_GECKO_VERSIONS= 31 34
_GECKO_TYPE= firefox
# Dependence lines for different Firefox versions
31_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:${PORTSDIR}/www/firefox-esr
-33_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:${PORTSDIR}/www/firefox
+34_DEPENDS= ${LOCALBASE}/lib/firefox/firefox:${PORTSDIR}/www/firefox
.if exists(${LOCALBASE}/bin/firefox)
_GECKO_INSTALLED_VER!= ${LOCALBASE}/bin/firefox --version 2>/dev/null
@@ -94,7 +94,7 @@ _GECKO_WANTED_VERSIONS:= ${_GECKO_VERSION:M[0-9][0-9]}
_GECKO_WANTED_VERSIONS?= ${_GECKO_DEFAULT_VERSION}
.if defined(_GECKO_MIN_VERSION)
-. for _v in _GECKO_VERSIONS
+. for _v in ${_GECKO_VERSIONS}
. if ${_GECKO_MIN_VERSION} <= ${_v}
_GECKO_WANTED_VERSIONS+= ${_v}
. endif