aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Uses
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-09-24 18:00:08 +0800
committerbapt <bapt@FreeBSD.org>2013-09-24 18:00:08 +0800
commit4c8299803e94057e3ebb8d03451231409761c960 (patch)
tree3c543503d19dc9f0b8cba37960a8d52236a846ed /Mk/Uses
parente45fa5bb403297a904dbe262a1fc6dfa79b4d695 (diff)
downloadfreebsd-ports-gnome-4c8299803e94057e3ebb8d03451231409761c960.tar.gz
freebsd-ports-gnome-4c8299803e94057e3ebb8d03451231409761c960.tar.zst
freebsd-ports-gnome-4c8299803e94057e3ebb8d03451231409761c960.zip
In preparation for package as user introduce a new uidfix, which will setup anything
need for a build system to allow staging as a user. For now only setup for port using bsd.prog.mk is available
Diffstat (limited to 'Mk/Uses')
-rw-r--r--Mk/Uses/uidfix.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/Mk/Uses/uidfix.mk b/Mk/Uses/uidfix.mk
new file mode 100644
index 000000000000..db0cd36ed4a2
--- /dev/null
+++ b/Mk/Uses/uidfix.mk
@@ -0,0 +1,15 @@
+# $FreeBSD$
+#
+# Changes some default behaviour of build systems to allow installing as user.
+#
+# MAINTAINER: bapt@FreeBSD.org
+#
+# Feature: uidfix
+# Usage: USES=uidfix
+# Valid ARGS: none
+#
+.if !defined(_INCLUDE_USES_UIDFIX_MK)
+.if ${UID} != 0
+MAKE_ENV+= BINOWN=${UID} SHAREOWN=${UID} CONFOWN=${UID}
+.endif
+.endif