aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Uses
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-11-18 21:45:56 +0800
committermat <mat@FreeBSD.org>2014-11-18 21:45:56 +0800
commit767f28139b83e87aca24c18e04107e2f8a60531a (patch)
treedacd4bdd948d88c77d0511e17cad399108077a97 /Mk/Uses
parent19b2a7f483b632cdd02959d7c766d801e6355c77 (diff)
downloadfreebsd-ports-gnome-767f28139b83e87aca24c18e04107e2f8a60531a.tar.gz
freebsd-ports-gnome-767f28139b83e87aca24c18e04107e2f8a60531a.tar.zst
freebsd-ports-gnome-767f28139b83e87aca24c18e04107e2f8a60531a.zip
Introduce the SITE_ARCH variable containing SITE_PERL/PERL_ARCH.
With hat: perl@, portmgr@ Sponsored by: Absolight
Diffstat (limited to 'Mk/Uses')
-rw-r--r--Mk/Uses/perl5.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/Mk/Uses/perl5.mk b/Mk/Uses/perl5.mk
index f61836ec5454..440f8f035bb6 100644
--- a/Mk/Uses/perl5.mk
+++ b/Mk/Uses/perl5.mk
@@ -23,6 +23,8 @@
# (value: perl5.14)
# SITE_PERL - Directory name where site specific perl packages go.
# This value is added to PLIST_SUB.
+# SITE_ARCH - Directory name where arch site specific perl packages go.
+# This value is added to PLIST_SUB.
# USE_PERL5 - If set, this port uses perl5 in one or more of the extract,
# patch, build, install or run phases. The fixpacklist is
# needed in some cases, when a .packlist is created, it may
@@ -96,6 +98,8 @@ PERL_PORT?= perl5.14
SITE_PERL_REL?= lib/perl5/site_perl/${PERL_VER}
SITE_PERL?= ${LOCALBASE}/${SITE_PERL_REL}
+SITE_ARCH_REL?= ${SITE_PERL_REL}/${PERL_ARCH}
+SITE_ARCH?= ${LOCALBASE}/${SITE_ARCH_REL}
PERL5= ${LOCALBASE}/bin/perl${PERL_VERSION}
PERL= ${LOCALBASE}/bin/perl
@@ -156,6 +160,7 @@ PLIST_SUB+= PERL_VERSION=${PERL_VERSION} \
PERL_VER=${PERL_VER} \
PERL_ARCH=${PERL_ARCH} \
PERL5_MAN3=lib/perl5/${PERL_VER}/man/man3 \
+ SITE_ARCH=${SITE_ARCH_REL} \
SITE_PERL=${SITE_PERL_REL}
# handle perl5 specific manpages
@@ -170,7 +175,7 @@ MANDIRS+= ${PREFIX}/lib/perl5/${PERL_VER}
_USE_PERL5+= configure
ALL_TARGET?= # empty
CONFIGURE_ARGS+=--install_path lib="${PREFIX}/${SITE_PERL_REL}" \
- --install_path arch="${PREFIX}/${SITE_PERL_REL}/${PERL_ARCH}" \
+ --install_path arch="${PREFIX}/${SITE_ARCH_REL}" \
--install_path script="${PREFIX}/bin" \
--install_path bin="${PREFIX}/bin" \
--install_path libdoc="${MAN3PREFIX}/man/man3" \