aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Uses
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-06-24 06:20:35 +0800
committermarino <marino@FreeBSD.org>2015-06-24 06:20:35 +0800
commit79a9b56d2a869e7c4b17ecbee4b4a6898ab67d3f (patch)
tree314651731338885ef789fdf94361fb0e78e75437 /Mk/Uses
parent5bed687d344a735dd192b02c875220bc8200bc4f (diff)
downloadfreebsd-ports-gnome-79a9b56d2a869e7c4b17ecbee4b4a6898ab67d3f.tar.gz
freebsd-ports-gnome-79a9b56d2a869e7c4b17ecbee4b4a6898ab67d3f.tar.zst
freebsd-ports-gnome-79a9b56d2a869e7c4b17ecbee4b4a6898ab67d3f.zip
Ada Framework: Switch to gcc5-aux, upgrade 6 packages at once
The transition from gcc-aux to gcc5-aux in the Ada framework has been blocked by the inability to build gtkada3 and, once resolved, GPS (due to tight locking with compiler). A few days ago, Adacore made their annual release of their main libre products, include GPS. However, some products were tightly coupled with the recent compilers, so in order to upgrade, the compiler had to be switched and dependencies require many ports to be upgraded at once: * lang/asis * devel/gnatcoll * devel/gps * x11-toolkits/gtkada3 * www/aws * www/aws-demos While the version upgrades were modest in most cases (gps, gtkada3), the amount of work put into each port was significant. There are too many improvements to mention here. A few include the removal of dynamic package lists and incorporating gnatcoll into gps to avoid building it twice. A private "exp-run" was done all on all 50+ Ada ports to ensure they still build. Also, a new argument was added to Uses/ada.mk, "run", that pulls in the GNAT compiler as a run depends. This was necessary for GPS that will not launch correctly without the compiler in place.
Diffstat (limited to 'Mk/Uses')
-rw-r--r--Mk/Uses/ada.mk12
1 files changed, 8 insertions, 4 deletions
diff --git a/Mk/Uses/ada.mk b/Mk/Uses/ada.mk
index a3fdb26dd38b..64eb89f64e38 100644
--- a/Mk/Uses/ada.mk
+++ b/Mk/Uses/ada.mk
@@ -6,7 +6,7 @@
#
# Feature: ada
# Usage: USES=ada
-# Valid ARGS: 49, 5
+# Valid ARGS: 49, 5, run
#
# MAINTAINER: marino@FreeBSD.org
@@ -20,13 +20,17 @@ ADAXX= gcc
. elif ${ada_ARGS:M5}
ADAXX= gcc5
. else
-. if defined(ADA_DEFAULT) && ${ADA_DEFAULT} == 5
-ADAXX= gcc5
-. else
+. if defined(ADA_DEFAULT) && ${ADA_DEFAULT} == 49
ADAXX= gcc
+. else
+ADAXX= gcc5
. endif
. endif
+. if ${ada_ARGS:Mrun}
+RUN_DEPENDS+= ${LOCALBASE}/${ADAXX}-aux/bin/ada:${PORTSDIR}/lang/${ADAXX}-aux
+. endif
+
BUILD_DEPENDS+= ${LOCALBASE}/${ADAXX}-aux/bin/ada:${PORTSDIR}/lang/${ADAXX}-aux
MAKE_ENV+= PATH=${LOCALBASE}/${ADAXX}-aux/bin:${PATH} \
ADA_PROJECT_PATH=${LOCALBASE}/lib/gnat