aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Uses
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2015-02-17 18:30:55 +0800
committertijl <tijl@FreeBSD.org>2015-02-17 18:30:55 +0800
commit88e1d47dacebd4c1628648d182df57d654add6cc (patch)
tree9191ac53ded3c4d129976db630f6a8ffc5283c3e /Mk/Uses
parentc7ba1ad3a75e18bb5f873bb3e1dd2cdb45d0b328 (diff)
downloadfreebsd-ports-gnome-88e1d47dacebd4c1628648d182df57d654add6cc.tar.gz
freebsd-ports-gnome-88e1d47dacebd4c1628648d182df57d654add6cc.tar.zst
freebsd-ports-gnome-88e1d47dacebd4c1628648d182df57d654add6cc.zip
Run intltoolize before running autoreconf when a port uses intltool and
configure.ac (or configure.in) contains '^(AC|IT)_PROG_INTLTOOL'. Intltoolize updates intltool related build scripts and m4 files that are used by autoreconf to generate configure. This change guarantees that the build scripts, configure and LOCALBASE/bin/intltool-* are all in sync. PR: 194393 Differential Revision: https://reviews.freebsd.org/D976 Submitted by: olivierd, kwm (modified) Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'Mk/Uses')
-rw-r--r--Mk/Uses/autoreconf.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/Mk/Uses/autoreconf.mk b/Mk/Uses/autoreconf.mk
index fdadef8c1f79..5cb691805dd4 100644
--- a/Mk/Uses/autoreconf.mk
+++ b/Mk/Uses/autoreconf.mk
@@ -75,6 +75,13 @@ do-autoreconf:
# Don't modify time stamps if the files already exist
@test -e ${CONFIGURE_WRKSRC}/${f} || ${TOUCH} ${CONFIGURE_WRKSRC}/${f}
.endfor
+.if defined(_USE_GNOME) && ${_USE_GNOME:Mintltool}
+ @(cd ${CONFIGURE_WRKSRC} && \
+ if test -f configure.ac; then configure=configure.ac; \
+ else configure=configure.in; fi && \
+ if ${EGREP} -q '^(AC|IT)_PROG_INTLTOOL' $${configure}; \
+ then ${LOCALBASE}/bin/intltoolize -f -c; fi)
+.endif
@(cd ${CONFIGURE_WRKSRC} && ${LOCALBASE}/bin/autoreconf -f -i)
.endif