aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Uses
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-12-23 09:42:10 +0800
committermat <mat@FreeBSD.org>2014-12-23 09:42:10 +0800
commit93b7390a342856abe25eb579ecd6b12c5545a73f (patch)
treefb81665f139b927d7048923e1d751f271c44d7fd /Mk/Uses
parentfc18d8447117c4f611245f0275c7cf0ee661ffb4 (diff)
downloadfreebsd-ports-gnome-93b7390a342856abe25eb579ecd6b12c5545a73f.tar.gz
freebsd-ports-gnome-93b7390a342856abe25eb579ecd6b12c5545a73f.tar.zst
freebsd-ports-gnome-93b7390a342856abe25eb579ecd6b12c5545a73f.zip
Catch other wrong occurences of SITE_PERL and SITE_ARCH.
Sponsored by: Absolight
Diffstat (limited to 'Mk/Uses')
-rw-r--r--Mk/Uses/perl5.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/Mk/Uses/perl5.mk b/Mk/Uses/perl5.mk
index 47438bd3a051..c3f7a2393695 100644
--- a/Mk/Uses/perl5.mk
+++ b/Mk/Uses/perl5.mk
@@ -175,8 +175,8 @@ MANDIRS+= ${PREFIX}/${SITE_PERL_REL}/man
.if ${_USE_PERL5:Mmodbuild} || ${_USE_PERL5:Mmodbuildtiny}
_USE_PERL5+= configure
ALL_TARGET?= # empty
-CONFIGURE_ARGS+=--install_path lib="${SITE_PERL}" \
- --install_path arch="${SITE_ARCH}" \
+CONFIGURE_ARGS+=--install_path lib="${PREFIX}/${SITE_PERL_REL}" \
+ --install_path arch="${PREFIX}/${SITE_ARCH_REL}" \
--install_path script="${PREFIX}/bin" \
--install_path bin="${PREFIX}/bin" \
--install_path libdoc="${MAN3PREFIX}/man/man3" \
@@ -232,7 +232,7 @@ RUN_DEPENDS+= ${PERL5}:${PORTSDIR}/lang/${PERL_PORT}
CONFIGURE_ARGS+= CC="${CC}" CCFLAGS="${CFLAGS}" PREFIX="${PREFIX}" \
INSTALLPRIVLIB="${PREFIX}/lib" INSTALLARCHLIB="${PREFIX}/lib"
CONFIGURE_SCRIPT?= Makefile.PL
-MAN3PREFIX?= ${SITE_PERL}
+MAN3PREFIX?= ${PREFIX}/${SITE_PERL_REL}
.undef HAS_CONFIGURE
.if !target(do-configure)