aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Uses
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2014-11-27 21:14:24 +0800
committermat <mat@FreeBSD.org>2014-11-27 21:14:24 +0800
commit94cb5ce7c33317307f07eea00824afe0274351af (patch)
treedda6b6ee3078a7e9352a89bd4860a1c87333ba0b /Mk/Uses
parentc0a92443834b82e62f7ec2c2649518c32db4600b (diff)
downloadfreebsd-ports-gnome-94cb5ce7c33317307f07eea00824afe0274351af.tar.gz
freebsd-ports-gnome-94cb5ce7c33317307f07eea00824afe0274351af.tar.zst
freebsd-ports-gnome-94cb5ce7c33317307f07eea00824afe0274351af.zip
Use TMPPLIST, not PLIST.
Sponsored by: Absolight
Diffstat (limited to 'Mk/Uses')
-rw-r--r--Mk/Uses/perl5.mk5
1 files changed, 2 insertions, 3 deletions
diff --git a/Mk/Uses/perl5.mk b/Mk/Uses/perl5.mk
index a756fc68aede..cc8581ba57ef 100644
--- a/Mk/Uses/perl5.mk
+++ b/Mk/Uses/perl5.mk
@@ -271,10 +271,9 @@ PACKLIST_DIR?= ${PREFIX}/${SITE_ARCH_REL}/auto
fix-perl-things:
# Remove STAGEDIR from .packlist and add the file to the plist.
@(if [ -d ${STAGEDIR}${PACKLIST_DIR} ] ; then \
- cd ${STAGEDIR} ; \
- find .${PACKLIST_DIR} -name .packlist | while read f ; do \
+ find ${STAGEDIR}${PACKLIST_DIR} -name .packlist | while read f ; do \
${SED} -i '' 's|^${STAGEDIR}||' "$$f"; \
- ${ECHO} $$f >> ${PLIST}; \
+ ${ECHO} $$f | ${SED} -e 's|^${STAGEDIR}||' >> ${TMPPLIST}; \
done \
fi) || :