aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Uses
diff options
context:
space:
mode:
authorAdriaan de Groot <adridg@FreeBSD.org>2021-02-11 07:19:17 +0800
committerAdriaan de Groot <adridg@FreeBSD.org>2021-02-11 07:19:17 +0800
commita0e9636c07016e3415f7622e530b0616b0dde68e (patch)
tree74ef9f24a4f934f538488942cc47917fad443fe1 /Mk/Uses
parenta63b07fe5539c4642be01e0b3b7c99037661fe20 (diff)
downloadfreebsd-ports-gnome-a0e9636c07016e3415f7622e530b0616b0dde68e.tar.gz
freebsd-ports-gnome-a0e9636c07016e3415f7622e530b0616b0dde68e.tar.zst
freebsd-ports-gnome-a0e9636c07016e3415f7622e530b0616b0dde68e.zip
Improve the upgrade path for Qt with portupgrade.
Newer Qt releases depend on the build tools and qmake from that release, but the existing way of specifying that (e.g. USE_QT=buildtools_build) could pick up the *old* Qt version's tools and qmake. Never a problem in poudriere, which builds cleanly, but it keeps tripping up other tools. Replace the existing definitions for the dependencies with versioned dependencies, so that the right version of tools is built and used for the rest of the Qt stack. PR: 245862 Reported by: Piotr Smyrak Reviewed by: tcberner
Diffstat (limited to 'Mk/Uses')
-rw-r--r--Mk/Uses/qt.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/Mk/Uses/qt.mk b/Mk/Uses/qt.mk
index ae99c5d28baf..3cf09bd62bae 100644
--- a/Mk/Uses/qt.mk
+++ b/Mk/Uses/qt.mk
@@ -151,8 +151,9 @@ qt-3d_LIB= libQt${_QT_LIBVER}3DCore.so
qt-assistant_PORT= devel/${_QT_RELNAME}-assistant
qt-assistant_PATH= ${LOCALBASE}/${QT_BINDIR_REL}/assistant
+# Always build with *this* version's buildtools
qt-buildtools_PORT= devel/${_QT_RELNAME}-buildtools
-qt-buildtools_PATH= ${LOCALBASE}/${QT_BINDIR_REL}/moc
+qt-buildtools_PATH= ${_QT_RELNAME}-buildtools>=${_QT_VERSION}
qt-charts_PORT= x11-toolkits/${_QT_RELNAME}-charts
qt-charts_LIB= libQt${_QT_LIBVER}Charts.so
@@ -256,8 +257,9 @@ qt-qdoc-data_PATH= ${LOCALBASE}/${QT_DOCDIR_REL}/global/config.qdocconf
qt-qev_PORT= x11/${_QT_RELNAME}-qev
qt-qev_PATH= ${LOCALBASE}/${QT_BINDIR_REL}/qev
+# Always build with *this* version's qmake
qt-qmake_PORT= devel/${_QT_RELNAME}-qmake
-qt-qmake_PATH= ${LOCALBASE}/${QT_BINDIR_REL}/qmake
+qt-qmake_PATH= ${_QT_RELNAME}-qmake>=${_QT_VERSION}
qt-quick3d_PORT= x11-toolkits/${_QT_RELNAME}-quick3d
qt-quick3d_LIB= libQt${_QT_LIBVER}Quick3D.so