aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Uses
diff options
context:
space:
mode:
authorfjoe <fjoe@FreeBSD.org>2016-02-10 20:18:20 +0800
committerfjoe <fjoe@FreeBSD.org>2016-02-10 20:18:20 +0800
commita771326028e8e67a7b11e70a2c588ae8fa3b06b0 (patch)
treefd6e15525c55c94271e024cd4e9195af28962788 /Mk/Uses
parentf42e54dd1f5f111bbdfd738bf69bf560e2182bb7 (diff)
downloadfreebsd-ports-gnome-a771326028e8e67a7b11e70a2c588ae8fa3b06b0.tar.gz
freebsd-ports-gnome-a771326028e8e67a7b11e70a2c588ae8fa3b06b0.tar.zst
freebsd-ports-gnome-a771326028e8e67a7b11e70a2c588ae8fa3b06b0.zip
Prefer installed version instead of insisting on using default version.
PR: 200569
Diffstat (limited to 'Mk/Uses')
-rw-r--r--Mk/Uses/pgsql.mk5
1 files changed, 4 insertions, 1 deletions
diff --git a/Mk/Uses/pgsql.mk b/Mk/Uses/pgsql.mk
index 30e6db57d879..e9274be12cbf 100644
--- a/Mk/Uses/pgsql.mk
+++ b/Mk/Uses/pgsql.mk
@@ -85,7 +85,7 @@ _WANT_PGSQL_VER?= ${pgsql_ARGS}
. endif
# Try to match default version, otherwise just take the first version
-# that matches
+# that matches. Prefer the installed version if it matches
. if !empty(_WANT_PGSQL_VER)
. for version in ${_WANT_PGSQL_VER}
. if ${PGSQL_DEFAULT} == ${version}
@@ -93,6 +93,9 @@ PGSQL_VER= ${version}
. endif
PGSQL_VER?= ${version}
. endfor
+. if defined(_PGSQL_VER) && ${_WANT_PGSQL_VER:M${_PGSQL_VER}} == ${_PGSQL_VER}
+PGSQL_VER= ${_PGSQL_VER}
+. endif
. if defined(_PGSQL_VER) && ${_PGSQL_VER} != ${PGSQL_VER}
IGNORE?= cannot install: the port wants postgresql-client version ${_WANT_PGSQL_VER} and you have version ${_PGSQL_VER} installed
. endif