aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Uses
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2013-12-26 00:43:24 +0800
committerdanfe <danfe@FreeBSD.org>2013-12-26 00:43:24 +0800
commitad1ce4f0d8ebbd5902d8db4a59d06afafe3e5aa2 (patch)
treedbde7c73e8b8741464c9dad28f36ba9ecf19f3d6 /Mk/Uses
parent19caca02900eaf3609359b224f4f38865de9a656 (diff)
downloadfreebsd-ports-gnome-ad1ce4f0d8ebbd5902d8db4a59d06afafe3e5aa2.tar.gz
freebsd-ports-gnome-ad1ce4f0d8ebbd5902d8db4a59d06afafe3e5aa2.tar.zst
freebsd-ports-gnome-ad1ce4f0d8ebbd5902d8db4a59d06afafe3e5aa2.zip
Traditionally, most (if not all) tamperings with ${TMPPLIST} were done
silently within the ports (similar to extraction and patching phases). Recently introduced Mk/Uses/kmod.mk does some grunt work for pkg-plist, like @[un]exec /usr/sbin/kldxref ... stuff via ${ECHO_CMD}, which makes build logs less neat. Mute them and MKDIR, remove an extra whitespace, and wrap one overly long line. Approved by: rene
Diffstat (limited to 'Mk/Uses')
-rw-r--r--Mk/Uses/kmod.mk9
1 files changed, 5 insertions, 4 deletions
diff --git a/Mk/Uses/kmod.mk b/Mk/Uses/kmod.mk
index ba1adb6e8736..4932b47ad1b7 100644
--- a/Mk/Uses/kmod.mk
+++ b/Mk/Uses/kmod.mk
@@ -43,17 +43,18 @@ _INCLUDE_USES_KMOD_POST_MK= yes
.PHONY: kmod-post-install
pre-install: ${STAGEDIR}${KMODDIR}
${STAGEDIR}${KMODDIR}:
- ${MKDIR} ${.TARGET}
+ @${MKDIR} ${.TARGET}
post-install: kmod-post-install
kmod-post-install:
- ${ECHO_CMD} "@exec /usr/sbin/kldxref ${KMODDIR}" >> ${TMPPLIST}
- ${ECHO_CMD} "@unexec /usr/sbin/kldxref ${KMODDIR}" >> ${TMPPLIST}
+ @${ECHO_CMD} "@exec /usr/sbin/kldxref ${KMODDIR}" >> ${TMPPLIST}
+ @${ECHO_CMD} "@unexec /usr/sbin/kldxref ${KMODDIR}" >> ${TMPPLIST}
.if defined(NO_STAGE)
/usr/sbin/kldxref ${KMODDIR}
.endif
.if ${KMODDIR} != /boot/modules
- ${ECHO_CMD} "@unexec rmdir ${KMODDIR} 2>/dev/null || true" >> ${TMPPLIST}
+ @${ECHO_CMD} "@unexec rmdir ${KMODDIR} 2>/dev/null || true" \
+ >> ${TMPPLIST}
.endif
.endif