aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Uses
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-11-30 02:22:32 +0800
committertijl <tijl@FreeBSD.org>2014-11-30 02:22:32 +0800
commitb3a361d8eb7b71f0b468fd98e66a366d09af5fcf (patch)
treedd9cb6760a88c6c8e370786a93ecef5ba96f616c /Mk/Uses
parent237bc033e6203c347316781328565cb5a7f8b2cf (diff)
downloadfreebsd-ports-gnome-b3a361d8eb7b71f0b468fd98e66a366d09af5fcf.tar.gz
freebsd-ports-gnome-b3a361d8eb7b71f0b468fd98e66a366d09af5fcf.tar.zst
freebsd-ports-gnome-b3a361d8eb7b71f0b468fd98e66a366d09af5fcf.zip
Split devel/gettext in devel/gettext-runtime and devel/gettext-tools. The
first contains runtime libraries such as libintl and the latter contains developer tools such as msgfmt. Ports that use gettext will usually need a LIB_DEPENDS on gettext-runtime and a BUILD_DEPENDS on gettext-tools. USES=gettext-runtime can be used to set a LIB/BUILD/RUN_DEPENDS on devel/gettext-runtime and USES=gettext-tools can be used to set a BUILD/RUN_DEPENDS on devel/gettext-tools. USES=gettext is now the same as "USES=gettext-runtime gettext-tools" meaning a LIB_DEPENDS on devel/gettext-runtime and a BUILD_DEPENDS on devel/gettext-tools. Update gettext to 0.19.3. Remove :oldver from converters/libiconv and devel/gettext-runtime. Leave symlinks with the old library versions to avoid the need to bump PORTREVISION on a large number of dependent ports. When most of the dependent ports have had normal version updates, PORTREVISION can be bumped on the remaining ones (low number) and the links can be removed. Fix some ports that installed files in lib/locale instead of share/locale. PR: 194038 Reviewed by: bapt Exp-run: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'Mk/Uses')
-rw-r--r--Mk/Uses/autoreconf.mk6
-rw-r--r--Mk/Uses/gettext-runtime.mk28
-rw-r--r--Mk/Uses/gettext-tools.mk25
-rw-r--r--Mk/Uses/gettext.mk25
4 files changed, 62 insertions, 22 deletions
diff --git a/Mk/Uses/autoreconf.mk b/Mk/Uses/autoreconf.mk
index ecd3c9ddd90a..849197fdeb90 100644
--- a/Mk/Uses/autoreconf.mk
+++ b/Mk/Uses/autoreconf.mk
@@ -52,7 +52,7 @@
.if !defined(_INCLUDE_USES_AUTORECONF_MK)
_INCLUDE_USES_AUTORECONF_MK= yes
-_USES_POST+= autoreconf
+_USES_POST+= autoreconf
BUILD_DEPENDS+= autoconf-2.69:${PORTSDIR}/devel/autoconf \
autoheader-2.69:${PORTSDIR}/devel/autoconf \
@@ -60,10 +60,6 @@ BUILD_DEPENDS+= autoconf-2.69:${PORTSDIR}/devel/autoconf \
aclocal-1.14:${PORTSDIR}/devel/automake \
automake-1.14:${PORTSDIR}/devel/automake
-.if ${USES:Mgettext} && empty(gettext_ARGS:Mrun)
-BUILD_DEPENDS+= autopoint:${PORTSDIR}/devel/gettext
-.endif
-
.if ${USES:Mlibtool} && empty(libtool_ARGS:Mbuild)
BUILD_DEPENDS+= libtoolize:${PORTSDIR}/devel/libtool
.endif
diff --git a/Mk/Uses/gettext-runtime.mk b/Mk/Uses/gettext-runtime.mk
new file mode 100644
index 000000000000..5c0dc02f9b2a
--- /dev/null
+++ b/Mk/Uses/gettext-runtime.mk
@@ -0,0 +1,28 @@
+# $FreeBSD$
+#
+# Handle dependency on the gettext-runtime (libintl) port
+#
+# Feature: gettext-runtime
+# Usage: USES=gettext-runtime or USES=gettext-runtime:ARGS
+# Valid ARGS: lib (default), build, run
+#
+# MAINTAINER: portmgr@FreeBSD.org
+
+.if !defined(_INCLUDE_USES_GETTEXT_RUNTIME_MK)
+_INCLUDE_USES_GETTEXT_RUNTIME_MK= yes
+
+.if empty(gettext-runtime_ARGS)
+gettext-runtime_ARGS= lib
+.endif
+
+.if ${gettext-runtime_ARGS:Mlib}
+LIB_DEPENDS+= libintl.so:${PORTSDIR}/devel/gettext-runtime
+.endif
+.if ${gettext-runtime_ARGS:Mbuild}
+BUILD_DEPENDS+= gettext:${PORTSDIR}/devel/gettext-runtime
+.endif
+.if ${gettext-runtime_ARGS:Mrun}
+RUN_DEPENDS+= gettext:${PORTSDIR}/devel/gettext-runtime
+.endif
+
+.endif
diff --git a/Mk/Uses/gettext-tools.mk b/Mk/Uses/gettext-tools.mk
new file mode 100644
index 000000000000..67f9546cb160
--- /dev/null
+++ b/Mk/Uses/gettext-tools.mk
@@ -0,0 +1,25 @@
+# $FreeBSD$
+#
+# Handle dependency on the gettext-tools port
+#
+# Feature: gettext-tools
+# Usage: USES=gettext-tools or USES=gettext-tools:ARGS
+# Valid ARGS: build (default), run
+#
+# MAINTAINER: portmgr@FreeBSD.org
+
+.if !defined(_INCLUDE_USES_GETTEXT_TOOLS_MK)
+_INCLUDE_USES_GETTEXT_TOOLS_MK= yes
+
+.if empty(gettext-tools_ARGS)
+gettext-tools_ARGS= build
+.endif
+
+.if ${gettext-tools_ARGS:Mbuild}
+BUILD_DEPENDS+= msgfmt:${PORTSDIR}/devel/gettext-tools
+.endif
+.if ${gettext-tools_ARGS:Mrun}
+RUN_DEPENDS+= msgfmt:${PORTSDIR}/devel/gettext-tools
+.endif
+
+.endif
diff --git a/Mk/Uses/gettext.mk b/Mk/Uses/gettext.mk
index 383c530f2ca0..9f758dde0499 100644
--- a/Mk/Uses/gettext.mk
+++ b/Mk/Uses/gettext.mk
@@ -1,30 +1,21 @@
# $FreeBSD$
#
-# handle dependency on the gettext (libintl) port
+# Sets a library dependency on gettext-runtime and a build dependency
+# on gettext-tools. Same as "USES=gettext-runtime gettext-tools".
#
# Feature: gettext
-# Usage: USES=gettext or USES=gettext:ARGS
-# Valid ARGS: build, run, lib (default, implicit)
+# Usage: USES=gettext
#
-# MAINTAINER: portmgr@FreeBSD.org
+# MAINTAINER: portmgr@FreeBSD.org
.if !defined(_INCLUDE_USES_GETTEXT_MK)
_INCLUDE_USES_GETTEXT_MK= yes
-_GETTEXT_DEPENDS= xgettext:${PORTSDIR}/devel/gettext
-
-.if empty(gettext_ARGS)
-gettext_ARGS= lib
+.if !empty(gettext_ARGS)
+IGNORE= USES=gettext does not take arguments
.endif
-.if ${gettext_ARGS} == "build"
-BUILD_DEPENDS+= ${_GETTEXT_DEPENDS}
-.elif ${gettext_ARGS} == "run"
-RUN_DEPENDS+= ${_GETTEXT_DEPENDS}
-.elif ${gettext_ARGS} == "lib"
-LIB_DEPENDS+= libintl.so:${PORTSDIR}/devel/gettext
-.else
-IGNORE= USES=gettext - invalid args: [${gettext_ARGS}] specified
-.endif
+.include "${USESDIR}/gettext-runtime.mk"
+.include "${USESDIR}/gettext-tools.mk"
.endif