aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Uses
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2014-10-20 15:33:00 +0800
committermarino <marino@FreeBSD.org>2014-10-20 15:33:00 +0800
commitd31d2e2b162f6a6df23d357edf8d36e0e5bbc21f (patch)
tree2b87631b34a8161d19608fce65dfa0bba250fff9 /Mk/Uses
parent9aebc56f0d02c73b0d5c4deb84c4908718fa41a6 (diff)
downloadfreebsd-ports-gnome-d31d2e2b162f6a6df23d357edf8d36e0e5bbc21f.tar.gz
freebsd-ports-gnome-d31d2e2b162f6a6df23d357edf8d36e0e5bbc21f.tar.zst
freebsd-ports-gnome-d31d2e2b162f6a6df23d357edf8d36e0e5bbc21f.zip
Add Mk/Uses/alias.mk
When on used FreeBSD, this tool doesn't do anything. However, when used on DragonFly, it will define __FreeBSD__ appropriately in CFLAGS which allows the port to build with minimal or no extra patches. Differential Revision: https://reviews.freebsd.org/D950 Reviewed by: portmgr Approved by: bapt (portmgr)
Diffstat (limited to 'Mk/Uses')
-rw-r--r--Mk/Uses/alias.mk31
1 files changed, 31 insertions, 0 deletions
diff --git a/Mk/Uses/alias.mk b/Mk/Uses/alias.mk
new file mode 100644
index 000000000000..16104549d15b
--- /dev/null
+++ b/Mk/Uses/alias.mk
@@ -0,0 +1,31 @@
+# $FreeBSD$
+#
+# Add __FreeSBD__ definition to CFLAGS
+# Used by DPorts when masquerading as FreeBSD allows port to build without
+# additional patches
+#
+# Feature: alias
+# Usage: USES=alias or USES=alias:ARGS
+# Valid ARGS: 8, 9 (default), 10, 11
+#
+# MAINTAINER: marino@FreeBSD.org
+
+.if !defined(_INCLUDE_USES_ALIAS_MK)
+_INCLUDE_USES_ALIAS_MK= yes
+
+.if ${OPSYS} == DragonFly
+
+.if empty(alias_ARGS)
+CFLAGS+= -D__FreeBSD__=9
+.else
+. if ${alias_ARGS} == 8 || ${alias_ARGS} == 10 \
+ || ${alias_ARGS} == 9 || ${alias_ARGS} == 11
+CFLAGS+= -D__FreeBSD__=${alias_ARGS}
+. else
+IGNORE= invalid MAJOR RELEASE argument (${alias_ARGS}) for USES=alias
+. endif
+.endif
+
+.endif # OPSYS == DragonFly
+
+.endif