aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Uses
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2020-01-09 21:32:54 +0800
committerMathieu Arnold <mat@FreeBSD.org>2020-01-09 21:32:54 +0800
commitd3f5fae6430c5ea7c39d13d199d712f59e3f55b2 (patch)
treee9ca3e88daa6135044b75b68e0c072be6c8f617c /Mk/Uses
parent0a82a7c0912bee406fa559989e271d190b571a7e (diff)
downloadfreebsd-ports-gnome-d3f5fae6430c5ea7c39d13d199d712f59e3f55b2.tar.gz
freebsd-ports-gnome-d3f5fae6430c5ea7c39d13d199d712f59e3f55b2.tar.zst
freebsd-ports-gnome-d3f5fae6430c5ea7c39d13d199d712f59e3f55b2.zip
Remove the legacy way of passing Python version.
This was used before flavors were a thing to make sure if you built port A with some python version, and it needed port B, port B would also be built with the same python version. PR: 243185 Reviewed by: antoine Differential Revision: https://reviews.freebsd.org/D23084
Diffstat (limited to 'Mk/Uses')
-rw-r--r--Mk/Uses/python.mk4
1 files changed, 0 insertions, 4 deletions
diff --git a/Mk/Uses/python.mk b/Mk/Uses/python.mk
index 0d10c42bbb87..9649e0386908 100644
--- a/Mk/Uses/python.mk
+++ b/Mk/Uses/python.mk
@@ -459,10 +459,6 @@ PY_FLAVOR= py${_PYTHON_VERSION:S/.//}
# try to find a different one, if the passed version fits into
# the supported version range.
PYTHON_VERSION?= python${_PYTHON_VERSION}
-.if !defined(PYTHON_NO_DEPENDS) && \
- ${PYTHON_VERSION} != python${PYTHON_DEFAULT}
-DEPENDS_ARGS+= PYTHON_VERSION=${PYTHON_VERSION}
-.endif
# NOTE:
#