aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Uses
diff options
context:
space:
mode:
authorDmitri Goutnik <dmgk@FreeBSD.org>2019-11-16 06:47:44 +0800
committerDmitri Goutnik <dmgk@FreeBSD.org>2019-11-16 06:47:44 +0800
commitdc092d46b3d639ee8623e6fd376111d6c36c77ad (patch)
treeaaf63023e28e0b87560bd926a1661eec9eaba92d /Mk/Uses
parenta2a0136a066b99b9387270d39c38f18a3552062f (diff)
downloadfreebsd-ports-gnome-dc092d46b3d639ee8623e6fd376111d6c36c77ad.tar.gz
freebsd-ports-gnome-dc092d46b3d639ee8623e6fd376111d6c36c77ad.tar.zst
freebsd-ports-gnome-dc092d46b3d639ee8623e6fd376111d6c36c77ad.zip
Mk/Uses/go.mk: Enable binary package building for Go ports on aarch64
Tentatively enable package building for Go ports on aarch64 to catch regressions early. Reviewed by: tobik, Mikaƫl Urankar <mikael.urankar@gmail.com> Approved by: tz (mentor, implicit) Differential Revision: https://reviews.freebsd.org/D22385
Diffstat (limited to 'Mk/Uses')
-rw-r--r--Mk/Uses/go.mk6
1 files changed, 5 insertions, 1 deletions
diff --git a/Mk/Uses/go.mk b/Mk/Uses/go.mk
index e14334936a66..741e954ff665 100644
--- a/Mk/Uses/go.mk
+++ b/Mk/Uses/go.mk
@@ -101,7 +101,11 @@ GO_ENV+= GOPATH="${WRKDIR}" \
GOBIN=""
.endif
-GO_PORT?= lang/go
+# Tentatively enable package building for Go ports on aarch64 to catch regressions early.
+# Can be removed after go1.14 is officially released in Jan 2020 and lang/go is updated to 1.14
+GO_PORT_aarch64= lang/go-devel
+GO_PORT?= ${GO_PORT_${ARCH}:Ulang/go}
+
BUILD_DEPENDS+= ${GO_CMD}:${GO_PORT}
.if ${go_ARGS:Mrun}
RUN_DEPENDS+= ${GO_CMD}:${GO_PORT}