aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Uses
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2014-12-09 00:48:38 +0800
committertijl <tijl@FreeBSD.org>2014-12-09 00:48:38 +0800
commite2300845f96fc1f90e03af0a746423bff0b0e770 (patch)
treefd2d9471767ad6e92fff12ef08f1cb015017f9f8 /Mk/Uses
parentb0b474e0ac449202a591c50a796cb0435cbf54fb (diff)
downloadfreebsd-ports-gnome-e2300845f96fc1f90e03af0a746423bff0b0e770.tar.gz
freebsd-ports-gnome-e2300845f96fc1f90e03af0a746423bff0b0e770.tar.zst
freebsd-ports-gnome-e2300845f96fc1f90e03af0a746423bff0b0e770.zip
Replace USES=libtool:oldver with USES=libtool or USES=libtool:keepla in
the 32 ports that still use it. Bump PORTREVISION on their dependent ports except the ones that depend on these: audio/libogg audio/libvorbis devel/pcre ftp/curl graphics/jpeg graphics/libart_lgpl graphics/tiff textproc/expat2 textproc/libxslt In these cases the same trick as in the recent gettext update is used. The ports install a symlink with the old library version. When enough of their dependent ports have had regular updates the remaining ones can get a PORTREVISION bump and the links can be removed. Also remove the devel/pcre dependency from USE_GNOME=glib20. It causes over 2200 packages to depend on devel/pcre while less than 200 actually link with it. The glib20 package still depends on devel/pcre so this should not make a difference for ports with USE_GNOME=glib20. Also, libdata/pkgconfig/glib-2.0.pc lists pcre as a private library so USE_GNOME=glib20 should not propagate it. PR: 195724 Exp-run by: antoine Approved by: portmgr (antoine)
Diffstat (limited to 'Mk/Uses')
-rw-r--r--Mk/Uses/libtool.mk26
-rw-r--r--Mk/Uses/openal.mk2
2 files changed, 9 insertions, 19 deletions
diff --git a/Mk/Uses/libtool.mk b/Mk/Uses/libtool.mk
index 7af1fcd2f767..de121b7cd257 100644
--- a/Mk/Uses/libtool.mk
+++ b/Mk/Uses/libtool.mk
@@ -34,21 +34,7 @@ patch-libtool:
-e '/link_all_deplibs[0-9A-Z_]*=/s/=unknown/=no/' \
-e '/objformat=/s/echo aout/echo elf/' \
-e "/freebsd-elf\\*)/,/;;/ { \
- /deplibs_check_method=/s/=.*/=pass_all/; }" \
- $${i} && ${TOUCH} -mr $${i}.bak $${i}; done
-
- @${FIND} ${WRKDIR} -type f -name ltmain.sh | \
- ${XARGS} ${REINPLACE_CMD} \
- -e '/if.*linkmode.*prog.*mode.*!= relink/s/if.*;/if :;/'\
- -e '/if.*prog.*linkmode.*relink !=.*mode/s/if.*;/if :;/'\
- -e '/if.*linkmode.*prog.*mode.* = relink/s/||.*;/;/' \
- -e '/if.*prog.*linkmode.*relink = .*mode/s/||.*;/;/' \
- -e 's/|-p|-pg|/|-B*|-p|-pg|/'
-
-.if ! ${libtool_ARGS:Moldver}
- @${FIND} ${WRKDIR} \( -name configure -or -name ltconfig \) \
- -type f | while read i; do ${SED} -i.bak \
- -e "/freebsd-elf\\*)/,/;;/ { \
+ /deplibs_check_method=/s/=.*/=pass_all/; \
/library_names_spec=.*\\.so/ \
s/=.*/='\$$libname\$$release.so\$$versuffix \
\$$libname\$$release.so\$$major \$$libname.so' \
@@ -66,11 +52,15 @@ patch-libtool:
s/darwin|linux|/darwin|freebsd-elf|linux|/' \
-e '/freebsd-elf)/,+2 { \
/major=/s/=.*/=.$$(($$current - $$age))/; \
- /versuffix=/s/=.*/="$$major.$$age.$$revision"/; }'
-.endif
+ /versuffix=/s/=.*/="$$major.$$age.$$revision"/; }' \
+ -e '/if.*linkmode.*prog.*mode.*!= relink/s/if.*;/if :;/'\
+ -e '/if.*prog.*linkmode.*relink !=.*mode/s/if.*;/if :;/'\
+ -e '/if.*linkmode.*prog.*mode.* = relink/s/||.*;/;/' \
+ -e '/if.*prog.*linkmode.*relink = .*mode/s/||.*;/;/' \
+ -e 's/|-p|-pg|/|-B*|-p|-pg|/'
patch-lafiles:
-.if ${libtool_ARGS:Mkeepla} || ${libtool_ARGS:Moldver}
+.if ${libtool_ARGS:Mkeepla}
@${FIND} ${STAGEDIR} -type f -name '*.la' | \
${XARGS} ${SED} -i '' -e "/dependency_libs=/s/=.*/=''/"
.else
diff --git a/Mk/Uses/openal.mk b/Mk/Uses/openal.mk
index a95ae086f462..af35422d207b 100644
--- a/Mk/Uses/openal.mk
+++ b/Mk/Uses/openal.mk
@@ -19,7 +19,7 @@ _valid_ARGS= al si soft alut
_si_DEPENDS= libopenal.so.0:${PORTSDIR}/audio/openal
_soft_DEPENDS= libopenal.so.1:${PORTSDIR}/audio/openal-soft
-_alut_DEPENDS= libalut.so.1:${PORTSDIR}/audio/freealut
+_alut_DEPENDS= libalut.so.0:${PORTSDIR}/audio/freealut
_OPENAL_LIBS= si soft
_DEFAULT_OPENAL= soft