aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/Uses
diff options
context:
space:
mode:
authormva <mva@FreeBSD.org>2015-01-08 01:22:07 +0800
committermva <mva@FreeBSD.org>2015-01-08 01:22:07 +0800
commite828107156770d1941a28f4ae9c87740c0c6349f (patch)
tree747cade4690b4fe5b456faf85b807d447f4e4846 /Mk/Uses
parenta97aec7dcf301fc4e71d1adce66f9cfbeaf89511 (diff)
downloadfreebsd-ports-gnome-e828107156770d1941a28f4ae9c87740c0c6349f.tar.gz
freebsd-ports-gnome-e828107156770d1941a28f4ae9c87740c0c6349f.tar.zst
freebsd-ports-gnome-e828107156770d1941a28f4ae9c87740c0c6349f.zip
- Remove support for deprecated python bits from the ports
framework. The following knobs are not supported anymore: USE_PYTHON=<yes|version+-|-version|version-version> USE_PYTHON_BUILD USE_PYTHON_RUN USE_PYDISTUTILS PYDISTUTILS_AUTOPLIST PYTHON_PY3K_PLIST_HACK PYDISTUTILS_NOEGGINFO PYTHON_CONCURRENT_INSTALL USE_PYTHON_PREFIX PR: 196477 Differential Revision: https://reviews.freebsd.org/D1416 Exp-run: antoine Reviewed by: antoine Approved by: portmgr (antoine) With hat: python
Diffstat (limited to 'Mk/Uses')
-rw-r--r--Mk/Uses/python.mk84
1 files changed, 0 insertions, 84 deletions
diff --git a/Mk/Uses/python.mk b/Mk/Uses/python.mk
index 378b7101f261..79b1f939c999 100644
--- a/Mk/Uses/python.mk
+++ b/Mk/Uses/python.mk
@@ -198,17 +198,6 @@
# Deprecated variables, which exist for compatibility and will be removed
# soon:
#
-# USE_PYDISTUTILS - Deprecated, use USE_PYTHON=distutils instead
-#
-# PYDISTUTILS_AUTOPLIST
-# - Deprecated, use USE_PYTHON=autoplist instead
-#
-# PYTHON_PY3K_PLIST_HACK
-# - Deprecated, use USE_PYTHON=py3kplist instead
-#
-# PYDISTUTILS_NOEGGINFO
-# - Deprecated, use USE_PYTHON=noegginfo instead
-#
# PYTHON_DEFAULT_VERSION
# PYTHON2_DEFAULT_VERSION
# PYTHON3_DEFAULT_VERSION
@@ -219,11 +208,6 @@
# - Deprecated, use PYTHON_PKGNAMEPREFIX instead
# default: -py${PYTHON_SUFFIX}
#
-# PYTHON_CONCURRENT_INSTALL
-# - Deprecated, use USE_PYTHON=concurrent instead
-#
-# USE_PYTHON_PREFIX - Deprecated, use USE_PYTHON=pythonprefix instead
-#
# PYDISTUTILS_INSTALLNOSINGLE
# - Deprecated without replacement
#
@@ -238,74 +222,6 @@ _PYTHON_PORTBRANCH= 2.7 # ${_PYTHON_VERSIONS:[1]}
_PYTHON_BASECMD= ${LOCALBASE}/bin/python
_PYTHON_RELPORTDIR= ${PORTSDIR}/lang/python
-# COMPAT KNOBS, remove them, once the tree is cleaned
-.undef _PY_COMPAT_OLD
-# We will reuse USE_PYTHON with a different meaning, so make sure that, while
-# we are in the transition phase from USE_PYTHON -> USES=python, it is mapped
-# and reassigned correctly
-.if defined(USE_PYTHON_BUILD) || defined(USE_PYTHON_RUN)
-# old style
-_PY_COMPAT_OLD= yes
-.elif defined(USE_PYTHON)
-.if ${USE_PYTHON} == "yes"
-# old style
-_PY_COMPAT_OLD= yes
-.elif ${USE_PYTHON:C/[-0-9.+]*//} == ""
-# old style X.Y, X.Y+, X.Y-, -X.Y, X.Y-Z.A
-_PY_COMPAT_OLD= yes
-.endif # ${USE_PYTHON} == "yes" ...
-.endif # defined(USE_PYTHON_BUILD) || defined(USE_PYTHON_RUN)
-
-.if defined(_PY_COMPAT_OLD)
-.if defined(USE_PYTHON)
-.if ${USE_PYTHON} != "yes"
-python_ARGS:= ${USE_PYTHON}
-.endif
-.else
-.if defined(USE_PYTHON_BUILD)
-.if ${USE_PYTHON_BUILD} != "yes"
-python_ARGS= ${USE_PYTHON_BUILD},build
-.else
-python_ARGS= build
-.endif
-.endif # defined(USE_PYTHON_BUILD)
-.if defined(USE_PYTHON_RUN)
-.if ${USE_PYTHON_RUN} != "yes"
-python_ARGS+= ${USE_PYTHON_RUN},run
-.else
-python_ARGS+= run
-.endif
-.endif # defined(USE_PYTHON_RUN)
-.endif # defined(USE_PYTHON)
-# Everything passed to python_ARGS, undef USE_PYTHON, since we will reuse
-# it with a different meaning below
-.undef USE_PYTHON
-.endif # defined(_PY_COMPAT_OLD)
-.undef _PY_COMPAT_OLD
-
-.if !defined(USE_PYTHON)
-USE_PYTHON=
-.if defined(USE_PYDISTUTILS)
-USE_PYTHON+= distutils
-.endif
-.if defined(PYDISTUTILS_AUTOPLIST)
-USE_PYTHON+= autoplist
-.endif
-.if defined(PYTHON_PY3K_PLIST_HACK)
-USE_PYTHON+= py3kplist
-.endif
-.if defined(PYTHON_CONCURRENT_INSTALL)
-USE_PYTHON+= concurrent
-.endif
-.if defined(USE_PYTHON_PREFIX)
-USE_PYTHON+= pythonprefix
-.endif
-.if defined(PYDISTUTILS_NOEGGINFO)
-USE_PYTHON+= noegginfo
-.endif
-.endif # !defined(USE_PYTHON)
-# COMPAT KNOBS END
-
# Make each individual feature available as _PYTHON_FEATURE_<FEATURENAME>
.for var in ${USE_PYTHON}
_PYTHON_FEATURE_${var:tu}= yes