aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.commands.mk
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2012-02-23 01:34:47 +0800
committerbapt <bapt@FreeBSD.org>2012-02-23 01:34:47 +0800
commite1cd547f065b7e6e547994f0e9f8562fb919dff2 (patch)
tree84a119145e0a4530e64557c5652f609c80321548 /Mk/bsd.commands.mk
parent21e10e0bda919f9eef114b74c0ee79ff8206fb0e (diff)
downloadfreebsd-ports-gnome-e1cd547f065b7e6e547994f0e9f8562fb919dff2.tar.gz
freebsd-ports-gnome-e1cd547f065b7e6e547994f0e9f8562fb919dff2.tar.zst
freebsd-ports-gnome-e1cd547f065b7e6e547994f0e9f8562fb919dff2.zip
- only include bsd.pkgng.mk once [1]
- only read bsd.pkgng.mk in post.mk [1] - move the command definition to bsd.command.mk [1] - fix check-vulnerable [2] Submitted by: avilla [1], rene [2]
Diffstat (limited to 'Mk/bsd.commands.mk')
-rw-r--r--Mk/bsd.commands.mk11
1 files changed, 11 insertions, 0 deletions
diff --git a/Mk/bsd.commands.mk b/Mk/bsd.commands.mk
index 90950162ebf4..a8013b916492 100644
--- a/Mk/bsd.commands.mk
+++ b/Mk/bsd.commands.mk
@@ -113,6 +113,16 @@ ECHO_CMD?= echo # Shell builtin
# Used to print all the '===>' style prompts - override this to turn them off.
ECHO_MSG?= ${ECHO_CMD}
+.if defined(WITH_PKGNG)
+PKG_BIN?= ${LOCALBASE}/sbin/pkg
+PKG_CMD?= ${PKG_BIN} register
+PKG_DELETE?= ${PKG_BIN} delete -y
+PKG_INFO?= ${PKG_BIN} info -g
+PKG_VERSION?= ${PKG_BIN} version
+PKG_CREATE?= ${PKG_BIN} create
+PKG_ADD?= ${PKG_BIN} add
+PKG_QUERY?= ${PKG_BIN} query
+.else
.if exists(${LOCALBASE}/sbin/pkg_info)
PKG_CMD?= ${LOCALBASE}/sbin/pkg_create
PKG_ADD?= ${LOCALBASE}/sbin/pkg_add
@@ -126,5 +136,6 @@ PKG_DELETE?= /usr/sbin/pkg_delete
PKG_INFO?= /usr/sbin/pkg_info
PKG_VERSION?= /usr/sbin/pkg_version
.endif
+.endif
.endif