aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.options.mk
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2017-04-18 04:24:46 +0800
committerkwm <kwm@FreeBSD.org>2017-04-18 04:24:46 +0800
commitb2c69103ba41532bd19cdd1ee49598aa9d9521cc (patch)
tree20efd8061f7885bc0cdd52ab2a2e5e1de5a9e965 /Mk/bsd.options.mk
parentbc2cac2547e386654a6cbd21fe7251fe970d44e0 (diff)
downloadfreebsd-ports-gnome-b2c69103ba41532bd19cdd1ee49598aa9d9521cc.tar.gz
freebsd-ports-gnome-b2c69103ba41532bd19cdd1ee49598aa9d9521cc.tar.zst
freebsd-ports-gnome-b2c69103ba41532bd19cdd1ee49598aa9d9521cc.zip
* Fix MESON_TRUE/MESON_FALSE comment, to mention the actualy meson argument.
* Rework option hanlding to be more clear and to avoid double negative. Submitted by: antoine@ Approved by: antoine@
Diffstat (limited to 'Mk/bsd.options.mk')
-rw-r--r--Mk/bsd.options.mk20
1 files changed, 10 insertions, 10 deletions
diff --git a/Mk/bsd.options.mk b/Mk/bsd.options.mk
index 48328dee9d8e..34f74d8b75e0 100644
--- a/Mk/bsd.options.mk
+++ b/Mk/bsd.options.mk
@@ -118,11 +118,11 @@
# content to MESON_ARGS.
#
# ${opt}_MESON_TRUE Will add to MESON_ARGS:
-# Option enabled --${content} true
-# Option disabled --${content} false
+# Option enabled -D${content}=true
+# Option disabled -D${content}=false
# ${opt}_MESON_FALSE Will add to MESON_ARGS:
-# Option enabled --${content} false
-# Option disabled --${content} true
+# Option enabled -D${content}=false
+# Option disabled -D${content}=true
#
# ${opt}_IMPLIES When opt is enabled, options named in IMPLIES will
# get enabled too.
@@ -536,8 +536,8 @@ CMAKE_ARGS+= ${${opt}_CMAKE_BOOL_OFF:C/.*/-D&:BOOL=false/}
. if defined(${opt}_MESON_TRUE)
MESON_ARGS+= ${${opt}_MESON_TRUE:C/.*/-D&=true/}
. endif
-. if defined(${opt}_MESON_TRUE_OFF)
-MESON_ARGS+= ${${opt}_MESON_TRUE_OFF:C/.*/-D&=false/}
+. if defined(${opt}_MESON_FALSE)
+MESON_ARGS+= ${${opt}_MESON_FALSE:C/.*/-D&=false/}
. endif
. for configure in CONFIGURE CMAKE MESON QMAKE
. if defined(${opt}_${configure}_ON)
@@ -589,11 +589,11 @@ CMAKE_ARGS+= ${${opt}_CMAKE_BOOL:C/.*/-D&:BOOL=false/}
. if defined(${opt}_CMAKE_BOOL_OFF)
CMAKE_ARGS+= ${${opt}_CMAKE_BOOL_OFF:C/.*/-D&:BOOL=true/}
. endif
-. if defined(${opt}_MESON_FALSE)
-MESON_ARGS+= ${${opt}_MESON_FALSE:C/.*/-D&=false/}
+. if defined(${opt}_MESON_TRUE)
+MESON_ARGS+= ${${opt}_MESON_TRUE:C/.*/-D&=false/}
. endif
-. if defined(${opt}_MESON_FALSE_OFF)
-MESON_ARGS+= ${${opt}_MESON_FALSE_OFF:C/.*/-D&=true/}
+. if defined(${opt}_MESON_FALSE)
+MESON_ARGS+= ${${opt}_MESON_FALSE:C/.*/-D&=true/}
. endif
. for configure in CONFIGURE CMAKE MESON QMAKE
. if defined(${opt}_${configure}_OFF)