aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2017-12-07 09:51:00 +0800
committerBryan Drewery <bdrewery@FreeBSD.org>2017-12-07 09:51:00 +0800
commit15714bc16469c0021d101f6ec77877d63bdbbf56 (patch)
treea42b88a67486f15feef8c1814e679a6ed5e4a0bb /Mk/bsd.port.mk
parent0038f24b3097072994e669418f3298bf58aff3bc (diff)
downloadfreebsd-ports-gnome-15714bc16469c0021d101f6ec77877d63bdbbf56.tar.gz
freebsd-ports-gnome-15714bc16469c0021d101f6ec77877d63bdbbf56.tar.zst
freebsd-ports-gnome-15714bc16469c0021d101f6ec77877d63bdbbf56.zip
Fix 'make -j'.
- Pass MAKEFLAGS down into do-depends properly. - Remove redundant dependencies, run-depends and lib-depends, from targets that already depend on earlier targets that depend on the needed targets. Reported by: emaste With hat: portmgr
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk5
1 files changed, 3 insertions, 2 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 1eb738f9055b..1ecc73966f17 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -4011,6 +4011,7 @@ ${deptype:tl}-depends:
dp_SCRIPTSDIR="${SCRIPTSDIR}" \
PORTSDIR="${PORTSDIR}" \
dp_MAKE="${MAKE}" \
+ dp_MAKEFLAGS='${.MAKEFLAGS}' \
${SH} ${SCRIPTSDIR}/do-depends.sh
.endif
.endfor
@@ -5385,7 +5386,7 @@ _STAGE_DEP= build
# STAGE is special in its numbering as it has install and stage, so install is
# the main, and stage goes after.
_STAGE_SEQ= 050:stage-message 100:stage-dir 150:run-depends \
- 151:lib-depends 200:apply-slist 300:pre-install \
+ 200:apply-slist 300:pre-install \
400:generate-plist 450:pre-su-install 475:create-users-groups \
500:do-install 550:kmod-post-install 600:fixup-lib-pkgconfig 700:post-install \
750:post-install-script 800:post-stage 850:compress-man \
@@ -5405,7 +5406,7 @@ _TEST_SEQ= 100:test-message 150:test-depends 300:pre-test 500:do-test \
800:post-test \
${_OPTIONS_test} ${_USES_test}
_INSTALL_DEP= stage
-_INSTALL_SEQ= 100:install-message 150:run-depends 151:lib-depends \
+_INSTALL_SEQ= 100:install-message \
200:check-already-installed
_INSTALL_SUSEQ= 300:fake-pkg 500:security-check