aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorFlorent Thoumie <flz@FreeBSD.org>2009-01-24 00:28:36 +0800
committerFlorent Thoumie <flz@FreeBSD.org>2009-01-24 00:28:36 +0800
commit340b57f8beb786be8990652b17d2e45f182346e6 (patch)
treec3e6d8718763fb6c4df9ddb40d2544e7ceccaccd /Mk/bsd.port.mk
parent66a81c62b92aa3373e54dc3b68238b43561f244f (diff)
downloadfreebsd-ports-gnome-340b57f8beb786be8990652b17d2e45f182346e6.tar.gz
freebsd-ports-gnome-340b57f8beb786be8990652b17d2e45f182346e6.tar.zst
freebsd-ports-gnome-340b57f8beb786be8990652b17d2e45f182346e6.zip
- Update X.org ports to 7.4+ (few ports are more recent than the katamari).
- Bump PORTREVISION for all ports depending on libglut since the shlib version number went from 4 to 3. - Bump PORTREVISION for all ports depending on libXaw as libXaw.so.8 isn't installed anymore. - Couple of ports fixes (mostly missing xorg components added to USE_XORG).
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 5fc6afc47783..dd96d3b677dc 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1373,7 +1373,7 @@ FILESDIR?= ${MASTERDIR}/files
SCRIPTDIR?= ${MASTERDIR}/scripts
PKGDIR?= ${MASTERDIR}
-.if defined(USE_IMAKE) && !defined(USE_X_PREFIX)
+.if defined(USE_IMAKE) && !defined(USE_X_PREFIX) && !defined(USE_XORG)
USE_X_PREFIX= yes
.endif
.if defined(USE_X_PREFIX) && ${USE_X_PREFIX} == "no"
@@ -1877,7 +1877,7 @@ PLIST_SUB+= XAWVER=${XAWVER}
_GL_gl_LIB_DEPENDS= GL.1:${PORTSDIR}/graphics/libGL
_GL_glu_LIB_DEPENDS= GLU.1:${PORTSDIR}/graphics/libGLU
_GL_glw_LIB_DEPENDS= GLw.1:${PORTSDIR}/graphics/libGLw
-_GL_glut_LIB_DEPENDS= glut.4:${PORTSDIR}/graphics/libglut
+_GL_glut_LIB_DEPENDS= glut.3:${PORTSDIR}/graphics/libglut
_GL_linux_RUN_DEPENDS= ${LINUXBASE}/usr/X11R6/lib/libGL.so.1:${PORTSDIR}/graphics/linux_dri
.if defined(USE_GL)