aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-08-17 17:11:00 +0800
committermat <mat@FreeBSD.org>2016-08-17 17:11:00 +0800
commit3e5b3ecc056d0cd5909b2ccd000d4c8997ecc335 (patch)
tree549db0297305183a4e9193149c119d1a4087e5c9 /Mk/bsd.port.mk
parentcacd715a7a308402b7bf878558adef8d055f349f (diff)
downloadfreebsd-ports-gnome-3e5b3ecc056d0cd5909b2ccd000d4c8997ecc335.tar.gz
freebsd-ports-gnome-3e5b3ecc056d0cd5909b2ccd000d4c8997ecc335.tar.zst
freebsd-ports-gnome-3e5b3ecc056d0cd5909b2ccd000d4c8997ecc335.zip
Split the PLIST_SUB_SED variable in smaller logical groups.
This will allow expanding it more easily. Sponsored by: Absolight
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk7
1 files changed, 5 insertions, 2 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 57a555e395d0..e4e3b70cddc0 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1604,13 +1604,16 @@ SUB_LIST+= PREFIX=${PREFIX} LOCALBASE=${LOCALBASE} \
WWWDIR=${WWWDIR} ETCDIR=${ETCDIR}
# This is used for check-stagedir.sh and check_leftover.sh to replace
# directories/files with PLIST_SUB %%KEYS%%.
+# Remove VARS which values are PLIST_SUB_SED_MIN long or shorter
+PLIST_SUB_SED_MIN?= 2
+PLIST_SUB_SED_tmp1= ${PLIST_SUB:C/.*=.{1,${PLIST_SUB_SED_MIN}}$//g}
# Remove VARS that are too generic
# Remove empty values
# Remove @comment values
+PLIST_SUB_SED_tmp2= ${PLIST_SUB_tmp1:NEXTRACT_SUFX=*:NOSREL=*:NLIB32DIR=*:NPREFIX=*:NLOCALBASE=*:NRESETPREFIX=*:N*="":N*="@comment*}
# Remove quotes
# Replace . with \. for later sed(1) usage
-PLIST_SUB_SED_MIN?= 2
-PLIST_SUB_SED?= ${PLIST_SUB:C/.*=.{1,${PLIST_SUB_SED_MIN}}$//g:NEXTRACT_SUFX=*:NOSREL=*:NLIB32DIR=*:NPREFIX=*:NLOCALBASE=*:NRESETPREFIX=*:N*="":N*="@comment*:C/([^=]*)="?([^"]*)"?/s!\2!%%\1%%!g;/g:C/\./\\./g}
+PLIST_SUB_SED?= ${PLIST_SUB_SED_tmp2:C/([^=]*)="?([^"]*)"?/s!\2!%%\1%%!g;/g:C/\./\\./g}
# kludge to strip trailing whitespace from CFLAGS;
# sub-configure will not # survive double space