aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorjkh <jkh@FreeBSD.org>1995-01-03 19:52:01 +0800
committerjkh <jkh@FreeBSD.org>1995-01-03 19:52:01 +0800
commit778c9b90c4c5f4977832ac21f274a2f914d95c17 (patch)
treeca65798a85f3e922bcc1582c26c48d7bacc7a44e /Mk/bsd.port.mk
parent7c49a2b0462e752f903a76990795c71825729269 (diff)
downloadfreebsd-ports-gnome-778c9b90c4c5f4977832ac21f274a2f914d95c17.tar.gz
freebsd-ports-gnome-778c9b90c4c5f4977832ac21f274a2f914d95c17.tar.zst
freebsd-ports-gnome-778c9b90c4c5f4977832ac21f274a2f914d95c17.zip
Add describe target support.
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk11
1 files changed, 10 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 8e4bfceb3b79..9e11b96ab8bc 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3,7 +3,7 @@
# bsd.port.mk - 940820 Jordan K. Hubbard.
# This file is in the public domain.
#
-# $Id: bsd.port.mk,v 1.89 1994/12/28 04:17:54 ache Exp $
+# $Id: bsd.port.mk,v 1.90 1995/01/01 20:06:20 ache Exp $
#
# Please view me with 4 column tabs!
@@ -277,6 +277,15 @@ patch:
# More standard targets start here.
+.if !target(describe)
+describe:
+ @if [ -f ${PKGDIR}/COMMENT ]; then \
+ echo "${.CURDIR}/${DISTNAME}: `cat ${PKGDIR}/COMMENT`"; \
+ else \
+ echo "${.CURDIR}/${DISTNAME}: ** No Description"; \
+ fi
+.endif
+
.if !target(reinstall)
reinstall: pre-reinstall install