aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-04-04 18:06:00 +0800
committersobomax <sobomax@FreeBSD.org>2002-04-04 18:06:00 +0800
commit9a13d3428f0f5d5de0f196a15c8fd6b61f00f631 (patch)
tree7af9e19e96282a55432ff1ad9feabf3bc755899d /Mk/bsd.port.mk
parent6cd228b835a1db2635e3979b872e6ca5cf593da1 (diff)
downloadfreebsd-ports-gnome-9a13d3428f0f5d5de0f196a15c8fd6b61f00f631.tar.gz
freebsd-ports-gnome-9a13d3428f0f5d5de0f196a15c8fd6b61f00f631.tar.zst
freebsd-ports-gnome-9a13d3428f0f5d5de0f196a15c8fd6b61f00f631.zip
Fix another "last" bug introduced with the speed-up commit. In some conditions
the bug resulted in "sh: Argument list too long" message during dependency registration process. Reported by: *many* Submitted by: Joe Marcus Clarke <marcus@marcuscom.com>
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk1
1 files changed, 1 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 417e5c03a73b..3fec1fc0cb71 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3154,6 +3154,7 @@ PACKAGE-DEPENDS-LIST= \
if (${ECHO} $$checked | ${GREP} -qwv "$$dir"); then \
childout=$$(cd $$dir; ${MAKE} CHILD_DEPENDS=yes PARENT_CHECKED="$$checked" package-depends-list); \
set -- $$childout; \
+ childname=""; childdir=""; \
while [ $$\# != 0 ]; do \
childname="$$childname $$1"; \
childdir="$$childdir $$2"; \