aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2014-09-19 23:44:55 +0800
committerbdrewery <bdrewery@FreeBSD.org>2014-09-19 23:44:55 +0800
commitb4c841487da5a6276a843f8c2a8ca7a42dc0313b (patch)
treeeee4af904617158d083e4b8122bd3b91ce0d6a69 /Mk/bsd.port.mk
parentdbcc619053235d7007205fc31b272c1be96f68b4 (diff)
downloadfreebsd-ports-gnome-b4c841487da5a6276a843f8c2a8ca7a42dc0313b.tar.gz
freebsd-ports-gnome-b4c841487da5a6276a843f8c2a8ca7a42dc0313b.tar.zst
freebsd-ports-gnome-b4c841487da5a6276a843f8c2a8ca7a42dc0313b.zip
- Remove -a when copying package. r329130 broke this when PACKAGES was on
NFS. It is not that important to preserve timestamp for the package, and other metadata seems to be fine otherwise. This whole thing needs to be reworked so PKGFILE is more respected (another regression of mine). With hat: portmgr Reported by: will Pointyhat to: bdrewery
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 526f925229f8..c560aea6de05 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -3612,7 +3612,7 @@ do-package: ${TMPPLIST}
@if ${SETENV} ${PKG_ENV} FORCE_POST="${_FORCE_POST_PATTERNS}" ${PKG_CREATE} ${PKG_CREATE_ARGS} -f ${PKG_SUFX:S/.//} -o ${WRKDIR}/pkg ${PKGNAME}; then \
if [ -d ${PKGREPOSITORY} -a -w ${PKGREPOSITORY} ]; then \
${LN} -f ${WRKDIR}/pkg/${PKGNAME}${PKG_SUFX} ${PKGFILE} 2>/dev/null \
- || ${CP} -af ${WRKDIR}/pkg/${PKGNAME}${PKG_SUFX} ${PKGFILE}; \
+ || ${CP} -f ${WRKDIR}/pkg/${PKGNAME}${PKG_SUFX} ${PKGFILE}; \
if [ "${PKGORIGIN}" = "ports-mgmt/pkg" -o "${PKGORIGIN}" = "ports-mgmt/pkg-devel" ]; then \
if [ ! -d ${PKGLATESTREPOSITORY} ]; then \
if ! ${MKDIR} ${PKGLATESTREPOSITORY}; then \