aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2014-05-25 23:42:52 +0800
committerBryan Drewery <bdrewery@FreeBSD.org>2014-05-25 23:42:52 +0800
commitbf30f17d1894269a03b3381066eacf2ce4b19532 (patch)
tree71f0892a4ab9bb68dd82e1c582042cfd6acb8a45 /Mk/bsd.port.mk
parent232590eb6980c20a2388eddf67a1b8f14e3c63f5 (diff)
downloadfreebsd-ports-gnome-bf30f17d1894269a03b3381066eacf2ce4b19532.tar.gz
freebsd-ports-gnome-bf30f17d1894269a03b3381066eacf2ce4b19532.tar.zst
freebsd-ports-gnome-bf30f17d1894269a03b3381066eacf2ce4b19532.zip
- When searching for lib-depends, show which file was found.
This also fixes "- found" showing alone when there are multiple matches. PR: ports/187084
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk3
1 files changed, 2 insertions, 1 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 36d393d1edd7..fbc798738dc8 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -5044,8 +5044,9 @@ lib-depends:
[ `file -b -L --mime-type $${_LIB_FILE}` = "application/x-sharedlib" ] || continue ; \
fi ; \
found=1 ; \
- ${ECHO_MSG} " - found"; \
+ ${ECHO_MSG} -n " - found ($${_LIB_FILE})"; \
done ; \
+ ${ECHO_MSG}; \
if [ $${found} -eq 0 ]; then \
${ECHO_MSG} " - not found"; \
${ECHO_MSG} "===> Verifying for $$lib in $$dir"; \