aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-09-19 16:05:05 +0800
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-09-19 16:05:05 +0800
commitcb471dbbdc733133c89a3e369f4098b378f9a96f (patch)
tree88a2a42dc250ea943bbc0ec8ecc37d869d720bea /Mk/bsd.port.mk
parent0103973e81fb2dbf9d126d7cfe0b484151f45788 (diff)
downloadfreebsd-ports-gnome-cb471dbbdc733133c89a3e369f4098b378f9a96f.tar.gz
freebsd-ports-gnome-cb471dbbdc733133c89a3e369f4098b378f9a96f.tar.zst
freebsd-ports-gnome-cb471dbbdc733133c89a3e369f4098b378f9a96f.zip
Move the target for sanity checking to the end of bsd.port.mk so that
WARNING and DEV_* can be defined anywhere While here, change sleep time from 5 to 10 so that users have time to read it [1] Suggested by: many [1]
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk37
1 files changed, 37 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 671f5b6a4791..4dbdb65c1d56 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -6491,6 +6491,43 @@ install-license:
@${DO_NADA}
.endif
+.if defined(WARNING)
+show-warnings:
+ @${ECHO_MSG} "/!\\ WARNING /!\\"
+.for m in ${WARNING}
+ @${ECHO_MSG} "${m}"
+.endfor
+ @${ECHO_MSG}
+ @sleep 10
+
+check-makefile:: show-warnings
+.endif
+
+.if defined(DEVELOPER)
+.if defined(DEV_WARNING)
+show-dev-warnings:
+ @${ECHO_MSG} "/!\\ ${PKGNAME}: Makefile warnings, please consider fixing /!\\"
+ @${ECHO_MSG}
+.for m in ${DEV_WARNING}
+ @${ECHO_MSG} "${m}"
+.endfor
+ @${ECHO_MSG}
+ @sleep 10
+check-makefile:: show-dev-warnings
+.endif
+
+.if defined(DEV_ERROR)
+show-dev-errors:
+ @${ECHO_MSG} "/!\\ ${PKGNAME}: Makefile errors /!\\"
+ @${ECHO_MSG}
+.for m in ${DEV_WARNING}
+ @${ECHO_MSG} "${m}"
+.endfor
+ @${ECHO_MSG}
+ @${FALSE}
+check-makefile:: show-dev-errors
+.endif
+.endif #DVELOPER
.endif
# End of post-makefile section.