aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-06-19 19:25:44 +0800
committermat <mat@FreeBSD.org>2016-06-19 19:25:44 +0800
commitf29308cd2c448c2843ab3f7fdfbd3e40566c0e25 (patch)
tree976c7ab510c8828deef279082e23b0e38a358680 /Mk/bsd.port.mk
parent4355a44f5fcc35a912543d35ebe0da429206a74e (diff)
downloadfreebsd-ports-gnome-f29308cd2c448c2843ab3f7fdfbd3e40566c0e25.tar.gz
freebsd-ports-gnome-f29308cd2c448c2843ab3f7fdfbd3e40566c0e25.tar.zst
freebsd-ports-gnome-f29308cd2c448c2843ab3f7fdfbd3e40566c0e25.zip
Add a few checks for (MASTER|PATCH)_SITES groups.
While make(1) is ok with variable names having quite a lot of strange characters in them, the fetch code mostly uses sh(1), where variable names can't include a dash (or pluses, or many other things). PR: 210251 210198 Submitted by: mat Exp-run by: antoine Sponsored by: The FreeBSD Foundation, Absolight Differential Revision: https://reviews.freebsd.org/D6779
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk12
1 files changed, 12 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 09aa3f76b905..0f08760d3164 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -2202,6 +2202,12 @@ _S_TEMP= ${_S:S/^${_S:C@/?:[^/:]+$@/@}//:S/^://}
. if !empty(_S_TEMP)
. for _group in ${_S_TEMP:S/,/ /g}
_G_TEMP= ${_group}
+. if ${_G_TEMP:C/[a-zA-Z0-9_]//g}
+check-makevars::
+ @${ECHO_MSG} "The ${_S} MASTER_SITES line has"
+ @${ECHO_MSG} "a group with invalid characters, only use [a-zA-Z0-9_]"
+ @${FALSE}
+. endif
. if ${_G_TEMP} == all || ${_G_TEMP} == ALL || ${_G_TEMP} == default
check-makevars::
@${ECHO_MSG} "Makefile error: the words all, ALL and default are reserved and cannot be"
@@ -2219,6 +2225,12 @@ _S_TEMP= ${_S:S/^${_S:C@/:[^/:]+$@/@}//:S/^://}
. if !empty(_S_TEMP)
. for _group in ${_S_TEMP:S/,/ /g}
_G_TEMP= ${_group}
+. if ${_G_TEMP:C/[a-zA-Z0-9_]//g}
+check-makevars::
+ @${ECHO_MSG} "The ${_S} PATCH_SITES line has"
+ @${ECHO_MSG} "a group with invalid characters, only use [a-zA-Z0-9_]"
+ @${FALSE}
+. endif
. if ${_G_TEMP} == all || ${_G_TEMP} == ALL || ${_G_TEMP} == default
check-makevars::
@${ECHO_MSG} "The words all, ALL and default are reserved and cannot be"
* get rid of libgnugetopt dependency for -CURRENT,sf2003-07-142-8/+8 * It's been several months since I took maintainership of thiserwin2003-07-101-1/+5 * fix ports/palm/coldsync: fix dumps coredaichi2003-07-031-0/+11 * libtool uber-patchade2003-06-272-2/+0 * Remove REINPLACE commands that were rolled into gnomehack.adamw2003-06-126-20/+0 * Fix MASTER_SITESerwin2003-06-081-1/+1 * Fix patching.marcus2003-06-071-18/+0 * There is no homepage now.sumikawa2003-05-231-5/+0 * Update to 2.0.9.marcus2003-05-2012-12/+20 * BROKEN on 5.1: bad C++kris2003-05-181-0/+4 * Update to 2.0.8.marcus2003-05-078-8/+8 * BROKEN: Does not compilekris2003-05-071-0/+2 * Fix build on -current.sumikawa2003-05-055-0/+45 * Handle OMF files properly.marcus2003-05-042-0/+4 * Update to 2.0.7.marcus2003-05-0410-18/+24 * Update to 2.0.6.marcus2003-04-3010-18/+10 * palm/prc-tools-binutils and palm/prc-tools-gcc are migrated intosumikawa2003-04-2712-275/+0 * Upgrade to 2.2. palm/prc-tools-binutils and palm/prc-tools-gcc are nowsumikawa2003-04-274-28/+273 * Remove USE_GNOMENG.marcus2003-04-216-6/+0 * s|<malloc.h>|<stdlib.h>|marcus2003-04-192-0/+6 * Add gnomepilot-conduits2 after a repo copy from gnomepilot-conduits.marcus2003-04-1919-262/+63 * * Update to 2.0.5marcus2003-04-156-16/+32 * Add missing pisock dependency.marcus2003-03-312-2/+4 * Add gnomepilot2.marcus2003-03-311-0/+1 * Add gnomepilot2 after a repo copy from gnomepilot. gnomepilot2 is themarcus2003-03-3118-258/+84 * Set IGNORE if !PACKAGE_BUILDING, not BROKEN. The missing distfile cankris2003-03-281-2/+2 * Clear moonlight beckons.ade2003-03-0728-14/+14 * Update to 3.3skv2003-03-043-3/+3 * Update: palm/plucker 1.2 -> 1.2_1edwin2003-02-242-0/+21 * This is a maintainer upgrade of ports/palm/jpilot to version 0.99.5edwin2003-02-244-8/+12 * de-pkg-comment.kuriyama2003-02-224-2/+2 * Fix build on -CURRENT (GCC3).naddy2003-02-221-0/+14 * De-pkg-comment.knu2003-02-2128-14/+14 * De-pkg-comment.knu2003-02-216-3/+3 * De-pkg-comment my non-ruby ports as well.knu2003-02-184-2/+2 * Update to 3.25skv2003-02-052-2/+2 * Fix build.obraun2003-02-011-0/+10 * o) Fix perl usage. Use sed_reinplace insteadlkoeller2003-01-216-9/+92 * Upgrade to 0.99.4sumikawa2003-01-204-11/+13 * Fix MASTER_SITEedwin2003-01-102-2/+2 * Remove a dead Mastersite.arved2003-01-081-2/+1 * I forgot. Bump portrevision because I modified the plist.alane2003-01-072-0/+2 * Finish fixing this port so I can build kdepim. Maintainer notified.alane2003-01-076-32/+64 * Fix LIBS/LDFLAGS so port will build. Maintainer notified. I need the]alane2003-01-072-6/+6 * Update to version 0.11.7.joe2003-01-076-26/+4 * Update to 0.1.71.marcus2003-01-029-15/+6 * Be sure to install the libraries together with the headers and themi2002-12-283-0/+38 * Upgrade to the latest stable version -- 2.2.5, which supports Palms inmi2002-12-286-72/+90 * Revert the PERL-to-REINPLACE conversion attempts. They were nevermi2002-12-262-4/+27 * Let others maintain these two ports.keichii2002-12-221-1/+1 * Port needs autoconf.edwin2002-12-211-0/+1 * Adda RUN_DEPENDS on gnomecontrolcenter. This will allow GNOME 2 users tomarcus2002-12-143-0/+6 * Drop maintainership.kuriyama2002-12-131-1/+1 * Master_site has gone walking, the file can be fetched from this site.edwin2002-12-122-3/+15 * Fix Build with recent bison ,arved2002-12-111-0/+34 * Sort entries.knu2002-11-281-1/+1 * Remove xcopilot, port supersceded by palm/pose.markp2002-11-248-187/+0 * Maintainer changeedwin2002-11-232-2/+2 * Fix 404 links.kuriyama2002-11-213-3/+3 * Make palm/syncmal building again: malloc.h -> stdlib.hedwin2002-11-161-0/+14 * find libjpegijliao2002-11-121-0/+2 * Make palm/syncmal building on -current again.edwin2002-11-111-0/+14 * o Rollback PORTCOMMENT modifications while this feature's implementationlioux2002-11-114-4/+2 * Update to 0.1.69.marcus2002-11-099-12/+6 * Maintainer upte to 0.99.3edwin2002-11-098-119/+43 * Use PORTCOMMENT in the Makefile, and whack the pkg-comment.adamw2002-11-074-2/+4