aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.sites.mk
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2017-02-01 00:54:21 +0800
committertijl <tijl@FreeBSD.org>2017-02-01 00:54:21 +0800
commit844eb16a686a8eaf36b88417fa047f2a37149374 (patch)
tree31bde26cde7c64937193d64587b12c96997aad8c /Mk/bsd.sites.mk
parent475d84cbbcf4a6fe952d02d30a5c2201b7236bbd (diff)
downloadfreebsd-ports-gnome-844eb16a686a8eaf36b88417fa047f2a37149374.tar.gz
freebsd-ports-gnome-844eb16a686a8eaf36b88417fa047f2a37149374.tar.zst
freebsd-ports-gnome-844eb16a686a8eaf36b88417fa047f2a37149374.zip
- Autodetect the installed linux_base port and use LINUX_DEFAULT only as
a last resort. - Construct a list of DISTFILES for every architecture (amd64, i386). Select one list for regular make and all lists for make makesum so linux ports can have one combined distinfo file. - Set DIST_SUBDIR?=centos so there's only one copy of common distfiles. - Use MASTER_SITES and DISTFILES groups so make fetch is a bit smarter. - Regenerate all distinfo files. - For linux_base-c6 (just like linux_base-c7 already does) turn bin, lib, lib64 and sbin into symbolic links to the same directory under usr. This fixes the problem where some programs/libraries exist under / on FreeBSD and /usr on Linux or vice versa and then depending on the order of search paths Linux programs may run/load FreeBSD programs/libraries and fail. - Turn usr/share/icons into a symbolic link to LOCALBASE/share/icons so Linux programs can find desktop theme icons. This eliminates the need for x11-themes/linux*-hicolor-icon-theme. - Rename pkg-plist.x86_64 to pkg-plist.amd64. - Regenerate all pkg-plist files. - Add @preexec to linux_base pkg-plist that moves existing files in bin, lib, lib64, sbin and icons to the new destination before the directories are turned into symbolic links. - Remove several empty directories from linux_base ports. - Sweep over all linux ports: use consistent style, remove old CONFLICTS, remove unused pkg-descr files, add NLS option,... - Remove old linux arts, esound and openssl-compat ports.
Diffstat (limited to 'Mk/bsd.sites.mk')
-rw-r--r--Mk/bsd.sites.mk9
1 files changed, 5 insertions, 4 deletions
diff --git a/Mk/bsd.sites.mk b/Mk/bsd.sites.mk
index b59045c7132b..5f86931b0c34 100644
--- a/Mk/bsd.sites.mk
+++ b/Mk/bsd.sites.mk
@@ -227,19 +227,20 @@ MASTER_SITE_EXIM+= \
.if !defined(IGNORE_MASTER_SITE_CENTOS_LINUX)
MASTER_SITE_CENTOS_LINUX+= \
- http://mirror.centos.org/%SUBDIR%/:DEFAULT,SOURCE \
- http://vault.centos.org/%SUBDIR%/:DEFAULT,SOURCE
+ http://mirror.centos.org/%SUBDIR%/:DEFAULT,amd64,i386 \
+ http://vault.centos.org/%SUBDIR%/:DEFAULT,amd64,i386,SOURCE
.endif
.if !defined(IGNORE_MASTER_SITE_EPEL)
MASTER_SITE_EPEL+= \
- http://dl.fedoraproject.org/pub/epel/6/${LINUX_ARCH}/ \
+ http://dl.fedoraproject.org/pub/epel/6/x86_64/:DEFAULT,amd64 \
+ http://dl.fedoraproject.org/pub/epel/6/i386/:DEFAULT,i386 \
http://dl.fedoraproject.org/pub/epel/6/SRPMS/:SOURCE
.endif
.if !defined(IGNORE_MASTER_SITE_EPEL7)
MASTER_SITE_EPEL7+= \
- http://dl.fedoraproject.org/pub/epel/7/${LINUX_ARCH}/%SUBDIR%/ \
+ http://dl.fedoraproject.org/pub/epel/7/x86_64/%SUBDIR%/:DEFAULT,amd64 \
http://dl.fedoraproject.org/pub/epel/7/SRPMS/%SUBDIR%/:SOURCE
.endif