aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.sites.mk
diff options
context:
space:
mode:
authorbdrewery <bdrewery@FreeBSD.org>2015-03-21 04:34:29 +0800
committerbdrewery <bdrewery@FreeBSD.org>2015-03-21 04:34:29 +0800
commitd4b9d93dd9a4711221556bac98b1f6e9d0aea487 (patch)
tree965a598cb09027f3ade932a986f93b6900a55e22 /Mk/bsd.sites.mk
parent9aed8f4bf6208b88ed82f28f01db03ddcc1e2f0e (diff)
downloadfreebsd-ports-gnome-d4b9d93dd9a4711221556bac98b1f6e9d0aea487.tar.gz
freebsd-ports-gnome-d4b9d93dd9a4711221556bac98b1f6e9d0aea487.tar.zst
freebsd-ports-gnome-d4b9d93dd9a4711221556bac98b1f6e9d0aea487.zip
USE_GITHUB: Strip slashes from GH_TAGNAME which impacts WRKSRC and DISTNAME.
The DISTNAME setting in bsd.sites.mk was moved lower due to GH_TAGNAME using := and DISTNAME depending on GH_TAGNAME. With hat: portmgr
Diffstat (limited to 'Mk/bsd.sites.mk')
-rw-r--r--Mk/bsd.sites.mk15
1 files changed, 8 insertions, 7 deletions
diff --git a/Mk/bsd.sites.mk b/Mk/bsd.sites.mk
index cc73aaec6030..c8fc963ee8ca 100644
--- a/Mk/bsd.sites.mk
+++ b/Mk/bsd.sites.mk
@@ -549,13 +549,6 @@ MASTER_SITES+= GHL
. if !defined(MASTER_SITES) || !${MASTER_SITES:MGH} && !${MASTER_SITES:MGHC}
MASTER_SITES+= GH
. endif
-# This new scheme rerolls distfiles. Also ensure they are renamed to avoid
-# conflicts. Use _GITHUB_REV in case github changes their zipping or structure
-# which has happened before.
-_GITHUB_REV= 0
-. if ${MASTER_SITES:MGH}
-DISTNAME:= ${DISTNAME}_GH${_GITHUB_REV}
-. endif
. endif
GH_ACCOUNT?= ${PORTNAME}
GH_PROJECT?= ${PORTNAME}
@@ -565,6 +558,14 @@ GH_TAGNAME?= ${DISTVERSION}
. else
# Use full PREFIX/SUFFIX and converted DISTVERSION
GH_TAGNAME?= ${DISTVERSIONFULL}
+GH_TAGNAME:= ${GH_TAGNAME:S,/,-,}
+# This new scheme rerolls distfiles. Also ensure they are renamed to avoid
+# conflicts. Use _GITHUB_REV in case github changes their zipping or structure
+# which has happened before.
+_GITHUB_REV= 0
+. if ${MASTER_SITES:MGH}
+DISTNAME:= ${DISTNAME}_GH${_GITHUB_REV}
+. endif
. endif
.endif
.endif