aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.wx.mk
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2019-02-27 20:06:57 +0800
committerAlexey Dokuchaev <danfe@FreeBSD.org>2019-02-27 20:06:57 +0800
commit87fa32e3ca3a2a6f4e5aa3651208d0542c5c1e3f (patch)
tree0034587d983f98f516346eac3d70dcb83bac9cd8 /Mk/bsd.wx.mk
parent9afb858ec7b63e7f704a866bd5657451f108ca1c (diff)
downloadfreebsd-ports-gnome-87fa32e3ca3a2a6f4e5aa3651208d0542c5c1e3f.tar.gz
freebsd-ports-gnome-87fa32e3ca3a2a6f4e5aa3651208d0542c5c1e3f.tar.zst
freebsd-ports-gnome-87fa32e3ca3a2a6f4e5aa3651208d0542c5c1e3f.zip
Fix several grammar mistakes and improve formatting (cosmetic changes).
Diffstat (limited to 'Mk/bsd.wx.mk')
-rw-r--r--Mk/bsd.wx.mk13
1 files changed, 7 insertions, 6 deletions
diff --git a/Mk/bsd.wx.mk b/Mk/bsd.wx.mk
index 0efbccd85dea..804f4827b108 100644
--- a/Mk/bsd.wx.mk
+++ b/Mk/bsd.wx.mk
@@ -10,6 +10,7 @@
# before bsd.port.pre.mk, but Python components will only work if Python
# variables (e.g. USE_PYTHON) are defined before it (this is a bsd.python.mk
# limitation), at least it is manually included.
+#
# USE_WX - Set to the list of wxWidgets versions that can be used by
# the port. The syntax allows the following elements:
# - Single version (e.g. "3.0").
@@ -44,8 +45,8 @@
# WX_CONFIG), and in second one "--with-wx=${LOCALBASE}" plus
# "--with-wx-config=${WX_CONFIG:T} (prefix and name).
# WX_PREMK - Define to determine version and define WX_CONFIG/WX_VERSION
-# after <bsd.port.pre.mk> (in case the port needs to manually run
-# the script).
+# after <bsd.port.pre.mk> (in case the port needs to manually
+# run the script).
# WANT_WX - Set to "yes" or a valid single version (no ranges, etc).
# In both cases it will detect the installed wxWidgets
# components and add them to the variable HAVE_WX. If a
@@ -53,15 +54,15 @@
# components in the other case it will contain a list of
# "component-version" pairs (e.g. wx-2.8, contrib-2.8, etc).
# It has to be used before bsd.port.pre.mk.
-# WANT_WX_VER - Set to the prefered wxWidgets version for the port. It must
+# WANT_WX_VER - Set to the preferred wxWidgets version for the port. It must
# be present in USE_WX or missing in USE_WX_NOT. This is
-# overriden by the user variable WITH_WX_VER if set. It can
+# overridden by the user variable WITH_WX_VER if set. It can
# contain multiple versions in order of preference (last ones
# are tried first).
#
# The following variables are intended for the user and can be defined in
# make.conf.
-# WITH_WX_VER - Define to the list of prefered versions in reverse order.
+# WITH_WX_VER - Define to the list of preferred versions in reverse order.
#
# The following variables are defined by this file, to be read from the port.
# WX_CONFIG - The path to the wx-config program (with different name).
@@ -146,7 +147,7 @@ _WX_FILE_python_3.0= ${PYTHON_SITELIBDIR}/wx-3.0-gtk3/wx/__init__.py
_WX_PORT_wx_3.1= x11-toolkits/wxgtk31
_WX_LIB_wx_3.1= wx_baseu-3.1
-# Set _WX_SHVER_comp_ver to 0 and _WX_FILE_comp_ver for libs appropiately.
+# Set _WX_SHVER_comp_ver to 0 and _WX_FILE_comp_ver for libs appropriately.
# Set _WX_DEPTYPE_comp_ver for "python" to "run", and others to "lib".
. for comp in ${_WX_COMPS_ALL}