aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2016-08-19 21:09:28 +0800
committermat <mat@FreeBSD.org>2016-08-19 21:09:28 +0800
commit0c6e6c49215b5c96c5f9cb9c287dfa5e544ed9dd (patch)
tree0d88983beb167f0bd7214a923df90490ad1029ce /Mk
parentb711a529fab7474427e3b435e2782d347c943ce1 (diff)
downloadfreebsd-ports-gnome-0c6e6c49215b5c96c5f9cb9c287dfa5e544ed9dd.tar.gz
freebsd-ports-gnome-0c6e6c49215b5c96c5f9cb9c287dfa5e544ed9dd.tar.zst
freebsd-ports-gnome-0c6e6c49215b5c96c5f9cb9c287dfa5e544ed9dd.zip
Fixup the PLIST_SUB_SED creation.
PR: 211995 Reported by: koobs Sponsored by: Absolight
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 2cbbda5e24ac..6eb8946c0934 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1606,9 +1606,9 @@ PLIST_SUB_SED_tmp1= ${PLIST_SUB:C/.*=.{1,${PLIST_SUB_SED_MIN}}$//g}
# Remove VARS that are too generic
# Remove empty values
# Remove @comment values
-PLIST_SUB_SED_tmp2= ${PLIST_SUB_tmp1:NEXTRACT_SUFX=*:NOSREL=*:NLIB32DIR=*:NPREFIX=*:NLOCALBASE=*:NRESETPREFIX=*:N*="":N*="@comment*}
+PLIST_SUB_SED_tmp2= ${PLIST_SUB_SED_tmp1:NEXTRACT_SUFX=*:NOSREL=*:NLIB32DIR=*:NPREFIX=*:NLOCALBASE=*:NRESETPREFIX=*:N*="":N*="@comment*}
# Handle VARS for which there is a _regex entry
-PLIST_SUB_SED_tmp3?= ${PLIST_SUB_SED_tmp1:C/(${PLIST_SUB:M*_regex=*:C/_regex=.*/=.*/:Q:S/\\ /|/g:S/\\//g})//:C/(.*)_regex=(.*)/\1=\2/}
+PLIST_SUB_SED_tmp3?= ${PLIST_SUB_SED_tmp2:C/(${PLIST_SUB:M*_regex=*:C/_regex=.*/=.*/:Q:S/\\ /|/g:S/\\//g})//:C/(.*)_regex=(.*)/\1=\2/}
# Remove quotes
# Replace . with \. for later sed(1) usage
PLIST_SUB_SED?= ${PLIST_SUB_SED_tmp3:C/([^=]*)="?([^"]*)"?/s!\2!%%\1%%!g;/g:C/\./\\./g}