aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorolivierd <olivierd@FreeBSD.org>2015-09-14 21:00:58 +0800
committerolivierd <olivierd@FreeBSD.org>2015-09-14 21:00:58 +0800
commit0fc656103805a4104d156f284331a5553742ca3c (patch)
tree0e74c07a27defce786961d09992baf6c0130d104 /Mk
parent2602234dadd400bf2b231941733d1d6118117008 (diff)
downloadfreebsd-ports-gnome-0fc656103805a4104d156f284331a5553742ca3c.tar.gz
freebsd-ports-gnome-0fc656103805a4104d156f284331a5553742ca3c.tar.zst
freebsd-ports-gnome-0fc656103805a4104d156f284331a5553742ca3c.zip
Rewrite detection of GTK+3 support
Differential Revision: https://reviews.freebsd.org/D3137
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/xfce.mk21
1 files changed, 14 insertions, 7 deletions
diff --git a/Mk/Uses/xfce.mk b/Mk/Uses/xfce.mk
index f0a225cab995..467626d4b8e3 100644
--- a/Mk/Uses/xfce.mk
+++ b/Mk/Uses/xfce.mk
@@ -37,12 +37,16 @@ libgui_LIB_DEPENDS= libxfcegui4.so:${PORTSDIR}/x11-toolkits/libxfce4gui
libgui_USE_XFCE_REQ= libutil
libmenu_LIB_DEPENDS= libxfce4ui-1.so:${PORTSDIR}/x11/libxfce4menu
+libmenu_DETECT= ${LOCALBASE}/lib/libxfce4ui-1.so
+libmenu_GTK3_DETECT= ${LOCALBASE}/lib/libxfce4ui-2.so
libmenu_USE_XFCE_REQ= xfconf
libutil_LIB_DEPENDS= libxfce4util.so:${PORTSDIR}/x11/libxfce4util
panel_LIB_DEPENDS= libxfce4panel-1.0.so:${PORTSDIR}/x11-wm/xfce4-panel
panel_RUN_DEPENDS= xfce4-panel:${PORTSDIR}/x11-wm/xfce4-panel
+panel_DETECT= ${LOCALBASE}/lib/libxfce4panel-1.0.so
+panel_GTK3_DETECT= ${LOCALBASE}/lib/libxfce4panel-2.0.so
panel_USE_XFCE_REQ= garcon libexo xfconf
thunar_LIB_DEPENDS= libthunarx-2.so:${PORTSDIR}/x11-fm/thunar
@@ -72,6 +76,15 @@ _USE_XFCE+= ${${comp}_USE_XFCE_REQ} ${comp}
USE_XFCE= ${_USE_XFCE:O:u}
.for comp in ${USE_XFCE}
+
+. if ${xfce_ARGS} == gtk3
+. if defined(${comp}_GTK3_DETECT)
+. if exists(${${comp}_DETECT}) && !exists(${${comp}_GTK3_DETECT})
+BROKEN+= GTK3 option needs to be set in ${comp}
+. endif
+. endif
+. endif
+
. if defined(${comp}_BUILD_DEPENDS)
BUILD_DEPENDS+= ${${comp}_BUILD_DEPENDS}
. endif
@@ -85,16 +98,10 @@ RUN_DEPENDS+= ${${comp}_RUN_DEPENDS}
. endif
.endfor
-.if ${USE_XFCE:M*gui} == libgui
+. if ${USE_XFCE:M*gui} == libgui
DEPRECATED?= Depends on unmaintained x11-toolkits/libxfce4gui
. endif
-.if ${xfce_ARGS} == gtk3
-. if exists(${LOCALBASE}/lib/libxfce4ui-1.so) && !exists(${LOCALBASE}/lib/libxfce4ui-2.so)
-BROKEN= GTK3 option needs to be set in x11/libxfce4menu
-. endif
-.endif
-
.endif # end of defined(USE_XFCE)
.endif