aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-05-06 23:31:45 +0800
committerbapt <bapt@FreeBSD.org>2013-05-06 23:31:45 +0800
commit1871356558d45d41bca0613b8c942a4c0afb4c38 (patch)
tree1cb2a85eefb4ee94dd410b90429972865fe74c46 /Mk
parentb73ccceea71e8c09fc6e776947b73aadf73441c6 (diff)
downloadfreebsd-ports-gnome-1871356558d45d41bca0613b8c942a4c0afb4c38.tar.gz
freebsd-ports-gnome-1871356558d45d41bca0613b8c942a4c0afb4c38.tar.zst
freebsd-ports-gnome-1871356558d45d41bca0613b8c942a4c0afb4c38.zip
Add new USES: ncurses and readline
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/ncurses.mk102
-rw-r--r--Mk/Uses/readline.mk25
2 files changed, 127 insertions, 0 deletions
diff --git a/Mk/Uses/ncurses.mk b/Mk/Uses/ncurses.mk
new file mode 100644
index 000000000000..b7d74542ba7d
--- /dev/null
+++ b/Mk/Uses/ncurses.mk
@@ -0,0 +1,102 @@
+# $FreeBSD$
+#
+# handle dependency on the ncurses port
+#
+# MAINTAINER: portmgr@FreeBSD.org
+#
+# Feature: ncurses
+# Usage: USES=ncurses
+# Valid ARGS: base port
+#
+# use/port can now set this options to the makefiles
+# NCURSES_RPATH= yes - pass RFLAGS options to CFLAGS
+#
+# Overridable defaults:
+# NCURSES_PORT= devel/ncurses
+#
+# The makefile sets this variables:
+# NCURSESBASE - "/usr" or ${LOCALBASE}
+# NCURSESLIB - path to the libs
+# NCURSESINC - path to the matching includes
+# NCURSESRPATH - rpath for dynamic linker
+#
+# BUILD_DEPENDS - are added if needed
+# RUN_DEPENDS - are added if needed
+
+.if !defined(_INCLUDE_USES_NCURSES_MK)
+_INCLUDE_USES_NCURSES_MK= yes
+
+.if !defined(ncurses_ARGS)
+. if !exists(${DESTDIR}/${LOCALBASE}/lib/libncurses.so) && exists(${DESTDIR}/usr/include/ncurses.h)
+ncurses_ARGS= base
+. endif
+ncurses_ARGS?= port
+.endif
+
+.if ${ncurses_ARGS} == base
+NCURSESBASE= /usr
+NCURSESINC= ${NCURSESBASE}/include
+
+. if exists(${LOCALBASE}/lib/libncurses.so)
+check-depends::
+ @${ECHO_CMD} "Dependency error: this port wants the ncurses library from the FreeBSD"
+ @${ECHO_CMD} "base system. You can't build against it, while a newer"
+ @${ECHO_CMD} "version is installed by a port."
+ @${ECHO_CMD} "Please deinstall the port or undefine WITH_NCURSES_BASE."
+ @${FALSE}
+. endif
+
+NCURSESPATH= /usr/lib:${LOCALBASE}/lib
+
+.elif ${ncurses_ARGS} == port
+NCURSESBASE= ${LOCALBASE}
+NCURSESINC= ${LOCALBASE}/include/ncurses
+
+. if !defined(NCURSES_PORT) && exists(${DESTDIR}/${LOCALBASE}/lib/libncurses.so)
+PKG_DBDIR?= ${DESTDIR}/var/db/pkg
+. if defined(WITH_PKGNG)
+. if defined(DESTDIR)
+PKGARGS= -c ${DESTDIR}
+. endif
+PKGARGS?=
+NCURSES_INSTALLED!= ${PKG_BIN} ${PKGARGS} which -qo ${LOCALBASE}/lib/libncurses.so || :
+. else
+NCURSES_INSTALLED!= find "${PKG_DBDIR}/" -type f -name "+CONTENTS" -print0 | \
+ xargs -0 grep -l "^lib/libncurses.so." | \
+ while read contents; do \
+ ncursesprefix=`grep "^@cwd " "$${contents}" | ${HEAD} -n 1`; \
+ if test "$${ncursesprefix}" = "@cwd ${LOCALBASE}" ; then \
+ echo "$${contents}"; break; fi; done; ${ECHO_CMD}
+. endif
+. endif
+.else
+.error USES=ncurses only accept 'port' and 'base' as arguments, got ${ncurses_ARGS}
+.endif
+NCURSES_INSTALLED?=
+
+.if ${NCURSES_INSTALLED} != ""
+. if defined(WITH_PKGNG)
+NCURSES_PORT= ${NCURSES_INSTALLED}
+NCURSES_SHLIBFILE!= ${PKG_INFO} -ql ${NCURSES_INSTALLED} | grep -m 1 "^`pkg query "%p" ${NCURSES_INSTALLED}`/lib/libncurses.so."
+. else
+NCURSES_PORT!= grep "^@comment ORIGIN:" "${NCURSES_INSTALLED}" | ${CUT} -d : -f 2
+NCURSES_SHLIBFILE!= grep -m 1 "^lib/libncurses.so." "${NCURSES_INSTALLED}"
+. endif
+NCURSES_SHLIBVER?= ${NCURSES_SHLIBFILE:E}
+.endif
+
+NCURSES_PORT?= devel/ncurses
+NCURSES_SHLIBVER?= 5
+
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libncurses.so.${NCURSES_SHLIBVER}:${PORTSDIR}/${NCURSES_PORT}
+RUN_DEPENDS+= ${LOCALBASE}/lib/libncurses.so.${NCURSES_SHLIBVER}:${PORTSDIR}/${NCURSES_PORT}
+NCURSESRPATH= ${LOCALBASE}/lib
+
+NCURSESLIB= ${NCURSESBASE}/lib
+
+.if defined(NCURSES_RPATH)
+CFLAGS+= -Wl,-rpath,${NCURSESRPATH}
+.endif
+LDFLAGS+= -Wl,-rpath=${NCURSESPATH}
+
+.endif
diff --git a/Mk/Uses/readline.mk b/Mk/Uses/readline.mk
new file mode 100644
index 000000000000..b3c5c4a95914
--- /dev/null
+++ b/Mk/Uses/readline.mk
@@ -0,0 +1,25 @@
+# $FreeBSD$
+#
+# handle dependency on the readline port
+#
+# MAINTAINER: portmgr@FreeBSD.org
+#
+# Feature: readline
+# Usage: USES=readline
+# Valid ARGS: port
+#
+
+.if !defined(_INCLUDE_USES_READLINE_MK)
+_INCLUDE_USES_READLINE_MK= yes
+
+.if ${OSVERSION} > 1000000
+readline_ARGS= port
+.endif
+
+.if defined(readline_ARGS) && ${readline_ARGS} == port
+LIB_DEPENDS+= readline.6:${PORTSDIR}/devel/readline
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib -lreadline
+.endif
+
+.endif