aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2002-06-14 02:20:40 +0800
committerMaxim Sobolev <sobomax@FreeBSD.org>2002-06-14 02:20:40 +0800
commit1c411ca96d5210baac780f876c0eb5dbd4d2dcb6 (patch)
treec0437ca3e24fa864c5a6f4be21f0f7acdecfcb36 /Mk
parentfb3735560d830a59f11e26c6ed0885a7b8127f47 (diff)
downloadfreebsd-ports-gnome-1c411ca96d5210baac780f876c0eb5dbd4d2dcb6.tar.gz
freebsd-ports-gnome-1c411ca96d5210baac780f876c0eb5dbd4d2dcb6.tar.zst
freebsd-ports-gnome-1c411ca96d5210baac780f876c0eb5dbd4d2dcb6.zip
Add ${REINPLACE_CMD}, which will be used to get rid of depencency on perl
in current. Use it like the following: ${REINPLACE_CMD} -e "foo" -e "bar" ${WRKSRC}/somefile Approved by: portmgr
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk7
1 files changed, 7 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index bd8676c091f4..7b466115e154 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -623,6 +623,13 @@ OSVERSION!= /usr/sbin/sysctl -n kern.osreldate
.endif
.endif
+# Special macro for doing in-place file editing using regexps
+.if ${OSVERSION} <= 500033
+REINPLACE_CMD?= ${PERL} -p -i.bak
+.else
+REINPLACE_CMD?= ${SED} -i.bak
+.endif
+
# Get the object format.
.if !defined(PORTOBJFORMAT)
PORTOBJFORMAT!= test -x /usr/bin/objformat && /usr/bin/objformat || echo aout