aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2016-04-28 20:17:09 +0800
committerAntoine Brodin <antoine@FreeBSD.org>2016-04-28 20:17:09 +0800
commit28b17725abe795dee3a55586b24e13f422a604e2 (patch)
treed740485da5ea5eb5f30a5110759ec1dc1e763d63 /Mk
parent5cc593fa9b1b7f587edb56c9d5ee5ea6b8c4a176 (diff)
downloadfreebsd-ports-gnome-28b17725abe795dee3a55586b24e13f422a604e2.tar.gz
freebsd-ports-gnome-28b17725abe795dee3a55586b24e13f422a604e2.tar.zst
freebsd-ports-gnome-28b17725abe795dee3a55586b24e13f422a604e2.zip
Remove ${PORTSDIR} from python _DEPENDS
Diffstat (limited to 'Mk')
-rw-r--r--Mk/Uses/python.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/Mk/Uses/python.mk b/Mk/Uses/python.mk
index abd4c1fecf5b..ceb6e8d70b76 100644
--- a/Mk/Uses/python.mk
+++ b/Mk/Uses/python.mk
@@ -225,7 +225,7 @@ _INCLUDE_USES_PYTHON_MK= yes
_PYTHON_VERSIONS= 2.7 3.4 3.5 3.3 # preferred first
_PYTHON_PORTBRANCH= 2.7 # ${_PYTHON_VERSIONS:[1]}
_PYTHON_BASECMD= ${LOCALBASE}/bin/python
-_PYTHON_RELPORTDIR= ${PORTSDIR}/lang/python
+_PYTHON_RELPORTDIR= lang/python
# Make each individual feature available as _PYTHON_FEATURE_<FEATURENAME>
.for var in ${USE_PYTHON}
@@ -396,8 +396,8 @@ PYTHON_REL= # empty
PYTHON_ABIVER= # empty
PYTHON_PORTSDIR= ${_PYTHON_RELPORTDIR}${PYTHON_SUFFIX}
# Protect partial checkouts from Mk/Scripts/functions.sh:export_ports_env().
-.if !defined(_PORTS_ENV_CHECK) || exists(${PYTHON_PORTSDIR})
-.include "${PYTHON_PORTSDIR}/Makefile.version"
+.if !defined(_PORTS_ENV_CHECK) || exists(${PORTSDIR}/${PYTHON_PORTSDIR})
+.include "${PORTSDIR}/${PYTHON_PORTSDIR}/Makefile.version"
.endif
# Create a 4 integer version string, prefixing 0 to the last token if
# it's a single character. Only use the the first 3 tokens of