aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2019-08-27 17:01:43 +0800
committerBaptiste Daroussin <bapt@FreeBSD.org>2019-08-27 17:01:43 +0800
commit293e996eb6a75cc144e243332d1019bcaacfcc8d (patch)
treec1044a42e9bda52aa3ae71aa9bd1ac4dd76a4534 /Mk
parent9ea8668beb1d97d2ddcfc57a4fae0c882901ca61 (diff)
downloadfreebsd-ports-gnome-293e996eb6a75cc144e243332d1019bcaacfcc8d.tar.gz
freebsd-ports-gnome-293e996eb6a75cc144e243332d1019bcaacfcc8d.tar.zst
freebsd-ports-gnome-293e996eb6a75cc144e243332d1019bcaacfcc8d.zip
Factorize if statements in fake-pkg
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk5
1 files changed, 1 insertions, 4 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 52e2325925f4..848f2c7a8ca4 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -4639,12 +4639,9 @@ STAGE_ARGS= -i ${STAGEDIR}
fake-pkg:
.if defined(INSTALLS_DEPENDS)
@${ECHO_MSG} "===> Registering installation for ${PKGNAME} as automatic"
-.else
- @${ECHO_MSG} "===> Registering installation for ${PKGNAME}"
-.endif
-.if defined(INSTALLS_DEPENDS)
@${SETENV} ${PKG_ENV} FORCE_POST="${_FORCE_POST_PATTERNS}" ${PKG_REGISTER} -d ${STAGE_ARGS} -m ${METADIR} -f ${TMPPLIST}
.else
+ @${ECHO_MSG} "===> Registering installation for ${PKGNAME}"
@${SETENV} ${PKG_ENV} FORCE_POST="${_FORCE_POST_PATTERNS}" ${PKG_REGISTER} ${STAGE_ARGS} -m ${METADIR} -f ${TMPPLIST}
.endif
@${RM} -r ${METADIR}