aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authormarino <marino@FreeBSD.org>2015-06-03 05:17:00 +0800
committermarino <marino@FreeBSD.org>2015-06-03 05:17:00 +0800
commit3c8cf21c495be065f5a325d2a60b89e1cd6059c8 (patch)
tree35cbc0e0d26d989bd8d21376d9d10e5292773283 /Mk
parentfd70c58f3a4e2abf5e6b37d4665a85727dec402f (diff)
downloadfreebsd-ports-gnome-3c8cf21c495be065f5a325d2a60b89e1cd6059c8.tar.gz
freebsd-ports-gnome-3c8cf21c495be065f5a325d2a60b89e1cd6059c8.tar.zst
freebsd-ports-gnome-3c8cf21c495be065f5a325d2a60b89e1cd6059c8.zip
bsd.port.mk: Implement BROKEN_${OPSYS} and BROKEN_${OPSYS}_${OSREL:R}
Examples of use: * BROKEN_FreeBSD= does not link * BROKEN_DragonFly= requires later jail * BROKEN_FreeBSD_8= long type-name is invalid The latter example could replace something like: .include <bsd.port.pre.mk> .if ${OPSYS} == FreeBSD && ${OSVERSION} <= 900000 BROKEN= long type-name is invalid .endif Differential Revision: https://reviews.freebsd.org/D2207 Reviewed by: portmgr Approved by: portmgr (mat)
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.port.mk21
1 files changed, 18 insertions, 3 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index e690a2e45d1b..f40c8b67111b 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -175,9 +175,16 @@ FreeBSD_MAINTAINER= portmgr@FreeBSD.org
# BROKEN - Port is believed to be broken. Package builds can
# still be attempted using TRYBROKEN to test this
# assumption.
-# BROKEN_${ARCH} Port is believed to be broken on ${ARCH}. Package builds
-# can still be attempted using TRYBROKEN to test this
-# assumption.
+# BROKEN_${ARCH} - Port is believed to be broken on ${ARCH}. Package builds
+# can still be attempted using TRYBROKEN to
+# test this assumption.
+# BROKEN_${OPSYS} - Port is believed to be broken on ${OPSYS}. Package builds
+# can still be attempted using TRYBROKEN to
+# test this assumption.
+# BROKEN_${OPSYS}_${OSREL:R} - Port is believed to be broken on a single
+# release of ${OPSYS}, e.g BROKEN_FreeBSD_8
+# would affect all point releases of FreeBSD 8
+# unless TRYBROKEN is also set.
# DEPRECATED - Port is deprecated to install. Advisory only.
# EXPIRATION_DATE
# - If DEPRECATED is set, determines a date when
@@ -2820,6 +2827,14 @@ IGNORE= is marked as broken: ${BROKEN}
.if !defined(TRYBROKEN)
IGNORE= is marked as broken on ${ARCH}: ${BROKEN_${ARCH}}
.endif
+.elif defined(BROKEN_${OPSYS}_${OSREL:R})
+.if !defined(TRYBROKEN)
+IGNORE= is marked as broken on ${OPSYS} ${OSREL}: ${BROKEN_${OPSYS}_${OSREL:R}}
+.endif
+.elif defined(BROKEN_${OPSYS})
+.if !defined(TRYBROKEN)
+IGNORE= is marked as broken on ${OPSYS}: ${BROKEN_${OPSYS}}
+.endif
.elif defined(FORBIDDEN)
IGNORE= is forbidden: ${FORBIDDEN}
.endif