aboutsummaryrefslogtreecommitdiffstats
path: root/Mk
diff options
context:
space:
mode:
authorgerald <gerald@FreeBSD.org>2011-10-31 04:58:22 +0800
committergerald <gerald@FreeBSD.org>2011-10-31 04:58:22 +0800
commit43baa50523cd969fb08bef722bc0871016a84e1c (patch)
tree036fe0b1b54af39512e4c6de8e9acf7fb652a3e8 /Mk
parente0d9676eaba81618c9c90b3044fa027673827c94 (diff)
downloadfreebsd-ports-gnome-43baa50523cd969fb08bef722bc0871016a84e1c.tar.gz
freebsd-ports-gnome-43baa50523cd969fb08bef722bc0871016a84e1c.tar.zst
freebsd-ports-gnome-43baa50523cd969fb08bef722bc0871016a84e1c.zip
Fix mis-applied patch from revision 1.59 (moving the new code one
conditional up). Discussed with: bf
Diffstat (limited to 'Mk')
-rw-r--r--Mk/bsd.gcc.mk9
1 files changed, 5 insertions, 4 deletions
diff --git a/Mk/bsd.gcc.mk b/Mk/bsd.gcc.mk
index 41f1fbdd9cb0..58900f124e82 100644
--- a/Mk/bsd.gcc.mk
+++ b/Mk/bsd.gcc.mk
@@ -160,12 +160,13 @@ _GCC_MIN2:= true
_GCC_FOUND:= ${_GCCVERSION_${v}_V}
. endif
. endfor
-.endif
-.if defined(_GCC_FOUND)
+
+. if defined(_GCC_FOUND)
_USE_GCC:= ${_GCC_FOUND}
-.elif ${_USE_GCC} < ${GCC_DEFAULT_VERSION}
+. elif ${_USE_GCC} < ${GCC_DEFAULT_VERSION}
_USE_GCC:= ${GCC_DEFAULT_VERSION}
-.endif
+. endif
+.endif # defined(_GCC_ORLATER)
.endif # defined(USE_GCC)